Has Anybody, Anywhere EVER got a storage device to work on an GL-AR750

After trying for most of the day, I’m starting to think it’s not supported yet.

I’ve updated firmware to latest, formated a 8GB MicroSD to NTFS & Ext4, Formatted USB stick to NTFS & Ext4, turned router off plugged them in-repowered AR750, Etc. Blah, Blah…
I can’t get the GL-Ar750 to recognize either of them.

have you checked dmesg to see if it’s being recognized? have you tried editing the fstab to mount the device?

I have- both USB and SD-Card. IIRC I used FAT32, but I can check tomorrow. Ping me if I forget to hit you back.

One notice, it doesn’t support plug and play. Must restart the router.

1 Like

FWIW, this is an SD-Card:

… and like @alzhao confirmed, you have to reboot once the storage device is connected.

“dmesg” and “fstab” are brand new terms for me. Are these found in the router software or external?

I’ll study up!!

Thank you!

alzhao:
I think I plugged them in and rebooted, but I’m not positive that I rebooted correctly…
Is “reboot” defined by unplugging power for a while and plugging back in
OR
Pressing the “Reset” button for more than ?? seconds, but less than 10 seconds? (I think over 10 seconds = Factory Reset)

Kennethrc:
That picture is exactly what I’m after!! Mine always says No Storage Devices Detected"

Thanks SO MUCH for the help y’all!!!
I’m wondering now if the problem isn’t something I’m doing wrong in the reboot.

I’m sure just power-on reboot. I didn’t have to reset, just make sure it was FAT32 and connected when powered on.

same issue here, cant see SD card but can see USB drive. have factory reset and checked formatting of SD card FAT32, NTFS…
i can see the SD card when SSH into the unit in the log files, but dosnt show in UI.

any help?

My apologies, my SD-Card is actually formatted as NTFS.

Here’s the output of “fdisk -lu”:

Disk /dev/sdc: 31.7 GB, 31674335232 bytes
255 heads, 63 sectors/track, 3850 cylinders, total 61863936 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0004fcee

Device Boot      Start         End      Blocks   Id  System
/dev/sdc1            2048    61863935    30930944    7  HPFS/NTFS/exFAT

… and of “parted -l”:

Model: Generic STORAGE DEVICE (scsi)
Disk /dev/sdc: 31.7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
1      1049kB  31.7GB  31.7GB  primary  ntfs

Can you post the log? You can use advanced settings (luci) -> status and find system and kernel log.

You can also ssh to the router and use the following to get the log

logread
dmesg

I am running the AR750s EXT. I can’t read the micro sd card either. When I cd /mnt and
ls -lh it it shows the EFI Partition and the Basic data partition only.
When I plug a usb hard drive it shows up, but not the micro SD. Any help?
I have tried formatting using the exfat and FAT32 using the Mac Disk Utility on Mac OS High Sierra.

I saw that you solved this issue in another post. The SD card is not pushed deep, pls clarify.

There is a very faint click where the Micro sd card needs to be pushed in like a digital camera that signifies the card is fully inserted and will not pop out. It does not simply slide in like when inserting the micro sd card into an adapter.

I’m having the exact same problem: I have an AR 750 that simply doesn’t recognize flash drives plugged into the USB port. In response to your question about logs @alzhao there’s nothing obvious in the system log (logmesg), but I did find this in the output of dmesg:

[ 6.401754] hub 1-1:1.0: 4 ports detected
[ 6.679018] usb 1-1.1: new high-speed USB device number 3 using ehci-platform
[ 6.794709] usb-storage 1-1.1:1.0: USB Mass Storage device detected
[ 6.801916] scsi host0: usb-storage 1-1.1:1.0
[ 6.879019] usb 1-1.2: new high-speed USB device number 4 using ehci-platform
[ 6.994634] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[ 7.001838] scsi host1: usb-storage 1-1.2:1.0
[ 7.800754] scsi 0:0:0:0: Direct-Access Generic STORAGE DEVICE 0233 PQ: 0 ANSI: 0
[ 7.814419] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 8.000880] scsi 1:0:0:0: Direct-Access Sony Storage Media 0100 PQ: 0 ANSI: 0 CCS
[ 8.012910] sd 1:0:0:0: [sdb] 7831552 512-byte logical blocks: (4.01 GB/3.73 GiB)
[ 8.021782] sd 1:0:0:0: [sdb] Write Protect is off
[ 8.026753] sd 1:0:0:0: [sdb] Mode Sense: 43 00 00 00
[ 8.027777] sd 1:0:0:0: [sdb] No Caching mode page found
[ 8.033308] sd 1:0:0:0: [sdb] Assuming drive cache: write through
[ 8.046023] sdb:
[ 8.050906] sd 1:0:0:0: [sdb] Attached SCSI removable disk

That’s completely consistent with the device I have plugged in, it’s a SONY 4 GB thumb drive, formatted FAT32. So it looks like the kernel is finding it just fine, there’s just no hint of it on the main non-Luci front page under USB devices.

I just got this today, it has the 2.272 firmware, and the update page does not show anything available. This isn’t a deal breaker at all for me, I primarily bought this for the 5GHz wifi support. Should I just wait for the 3.xxx firmware to be released through the auto-upload channel?

I really don’t want to try and upgrade it by hand, since I’m leaving in less than a week for a trip where I must have this operational as a wifi access point. Making a mistake during the flashing and bricking the router just isn’t a risk I can afford to take.

Couple things:

1 - you’ve booted the router with the flash-drive inserted, right? I think there’s a disconnect between the kernel recognizing flash devices (which happens asynchronously) vs. when the UI does (which IIRC, only happens at boot time)

2 - you have to really go out of your way to brick one of these units; I flashed the completely wrong FW once and was able to unbrick just fine

Yes, I tried plugging in the USB flash drive, and then both rebooting via the web interface, and a complete power down and restart. At this point, it’s not enough of a problem that I’ll worry about it. When the 3.xx firmware rolls out via the automatic update I’ll take another look at this and see what’s what.

For now, If I absolutely need a shared USB drive for media or whatever, I can work around this by plugging it into one of my computers, and then using File and Printer sharing to make it available on the LAN.

Seems the usb is recognized. Can you try Anthony commands

df
mount

This will show if the drive is mounted.

In firmware v3.x, there is no UI but it will mount and share. You can use your windows network to check.

@alzhao I tried the “df” / “mount” commands while connected via ssh with a USB thumb drive attached. The output of those indicated I had the usb drive mounted, but all I can say is that the SMB / CIFS server needs some work. I should have been able to open \\<router_ip_address>\ in Windows explorer to see the share. No such luck, it refused to connect.

At this point, I’ve officially thrown in the towel on this one, it’s just not worth my time any more to try and get this working. Since I now have a Windows 10 system acting as a NAS / Media share system, it’s orders of magnitude easier to just plug the thumb drive into that, and share with standard Windows file and printer sharing.

Seems you are using WAN IP address to connect? That will be refused.

The USB network share should be just plug and play.