Hello, and Help? :) :(

Hello alzhao,

First, wishing you a prosperous New Year. We’re gearing up here for the holiday as well. Nothing major, we’re just going to have a big dinner, along with friends and family.

I’ve just received my GL-AR150 in the mail today. I love it. It works great, as far as I can tell–this is my first experience with OpenWRT. Was busying trying to figure out what all of the menu options in LuCI meant. Unfortunately, most of the OpenWRT docs are for commandline usage, so there’s a steep learning curve for me to climb (I don’t much of Linux networking either).

Anyway, I was browsing on this forum, and saw that someone had success flashing Reaver Pro 2, so thought I gave it a go. I used the LuCI interface for flashing. Unfortunately, for whatever reason, it failed, and the router became non-responsive.

Using the routine at (404 Page not found - GL.iNet), ie hold down Reset until you get 5 flashes, I was able to get the router to respond to pings at Unfortunately, attempts to access via web browser, telnet, and SSH all fail.

I’m assuming that since the router is not hard bricked, since pings work, but have no idea on how to proceed. Your help would be much appreciated.

As said, I am an OpenWRT virgin, and a Linux noob, but I’m familiar with the commandline, and have debricked some DD-WRT routers in the past. This will be a learning experience, and I’m hoping it will be a productive one. Thank you in advance.


I’ve tried to access the AR150 through ftp, telnet, ssh, web, and unit is unresponsive. It does respond to pings. I don’t have a USB-serial converter, so serial access isn’t possible. My last hope would seem to be tftp (assuming the AR150 bootloader includes a tftp server). Using Windows’ built-in tftp,

tftp -i put openwrt-ar150-2.13.bin

which timeout after a few minutes.

I would greatly appreciate any assistance, or even an acknowledgement that this unit is indeed dead for all practical purpose, despite being responsive to pings.

Thanks for any and all help.

Hi tomj,

I would guess the guys at GL are enjoying the new year’s festivities.

In the mean time my 2 cents.

I find it strange that you can ping the device but are unable to connect to

Just checking, are you absolutely 100% sure that your machine on the other end of the ethernet cable is set to a static IP address of with a subnet mask of ? (I agree it is strange as you wouldn’t be able to ping the device either if that was not the case)

I would try again to start the uboot web ui with the reset procedure described in the docs. It really should give you the landing page where you can upload new firmware.

TFTP is only pull, not push, so it will only work when you have established console access and invoke the command from uboot itself to your tftp server on your other machine. But, for that you would need the USB serial again…

If it doesn’t work it almost feels like Reaver somehow replaced uboot as well, crazy as it may sound. But only way to be sure is once again to take a look at the serial output when the device is booting which would require a serial connection again.

Hi Jan!

Yes, it’s was getting a bit weird talking to myself! Hahah, actually, I’m Asian as well, and as said, it’s also the New Year for us, so I understand totally. But it’s great that there’s actually somebody who responded to me! THANK YOU just for that!

Yes, I had set the PC to static Router only responds to pings after the “hold down reset upon power-up till 5 flashes” routine, else pings also fail. Web access fails regardless with a 404, and I’ve tried many times. Telnet/SSH/ftp likewise fail with a connection error.

I’m primarily following this doc,

The doc doesn’t explain much about serial access, but from reading another OpenWRT doc on serial cables, I’m thinking of ordering this FTDI USB-to-TTL cable,


my only reservation is whether it can use the FTDI driver for Windows 10–in other words, whether it’s a genuine FTDI chip–and I’ve posted the question to the vendor.

From the GL doc above, I’m assuming that GL U-boot has a tftp client, so will try that once all the parts get here. I’ve also ordered a 2nd AR150, and hopefully it won’t brick so fast this time around!

Question to you, since you’re here(!): Was it an error for me to flash the Reaver Pro 2 firmware from the LuCI UI? That’s what bricked the unit. I read that Rene (from another thread) had success, so thought it would’ve been OK to try. Anyway, it’s a good learning experience if nothing else.

On a more general note, aside from the OpenWRT.org site, are there any other resources for a noob to learn about OpenWRT and Linux networking? There are many options in the LuCI UI that I’m unfamiliar with, and Googling each option separately is time-consuming. I’ve got a RPi and am using it to learn Linux, so it’s a two-pronged effort.

In any case, thanks again for your response and help. Here’s to hoping I can get a bit smarter!

Nice meeting you!

I will try to get back to you on some interesting OpenWRT leads. A bit busy right now but will keep my eyes peeled.

With regard to your question. I don’t know Reaver Pro that well although it looks to me like any other openwrt project so it shouldn’t do any harm other than leaving you unable to access the router. Have you considered googling around for reaver pro de-bricking techniques? It seems far fetched but I get the distinct impression that somehow your u-boot got changed by the flash as well. (however unlikely and impossible that may be)

Also, just because I cannot get my head around it. Your local LAN network (or WLAN for that matter) doesn’t accidently span the same address range ( does it? If so it might throw off even the static routing to because your LAN router might have the same IP. I know it is basic stuff but just trying to guess what is going on.

Do you have another old laptop or something lying about that you can try to hook the ethernet cable and AR-150 up to completely isolated from the rest of the network? It might eliminate some variables, although you might have tried that already of course.




>Have you considered googling around for reaver pro de-bricking techniques?

Good idea. I did just that, and it looks like Reaver is similar to OpenWRT with respect to recovery, ie getting a USB-TTL converter, running tftpd, and using similar commands. It still boils down to having a USB-serial cable, so that’s coming.

Re: Reaver overwriting U-boot - I don’t know, as I’ve only knew about U-boot since yesterday. :slight_smile: Fortunately in this case, OpenWRT does have a fairly good write-up on U-boot config, so I’m in good hands there.

Re: LAN isolation - Yeah, I disconnected the LAN (it’s on a different subnet in any case). Had to, since the (desktop) PC only has one Ethernet port, and no wifi adapter.

I have to say, it’s good to have a friendly ear. I’ve used DD-WRT and Tomato (Shibby), and have always wanted to try OpenWRT in years past. But I was put off by its lack of a front-end and few docs. Recently, I had a spare router (TL-WDR3600) that I installed OpenWRT for a look-see, and was very glad to see that it sported a graphical front-end now (LuCI).

My immediate goals are to learn the options available in LuCI, then hopefully I’ll graduate to trying out the underlying tools and their options. I love new toys! :slight_smile:

New Year’s Greetings from Seattle, WA, USA.

@tomj, if you want to learn OpenWrt and embedded Linux, having an USB-UART adapter is a great help.

I don’t think flashing firmware via Luci will overwrite your uboot. So you should be able to debrick the device. Here are some key points:

  1. When you hold the button and have 5 flashes, another LEDs will turn on
  2. Connect the cable before you power on the device. Only one cable to either LAN or WAN port. Don't connect two cables.
  3. Set your computer's IP to, or 1.10 etc.
  4. Use browser to access Some tricks here. If you got a 404, check if you are redirected to or something else. This may be the case that you used a clean OpenWrt firmware with Luci. to avoid this, browse by adding "?" at the end, it asked the browser not to use cache.
Good luck

>to avoid this, browse by adding “?” at the end, it asked the browser not to use cache.

Whoa! That worked! THANK YOU! :slight_smile: :slight_smile:

I think this was in your DIY_flashing link above even. Sorry, noob mistake… :frowning: