Help! Beryl cannot connect to home mesh wifi as a repeater


Just got the Beryl (MT-1300) and tried to connect it in Repeater mode to my home mesh network, without success. Please help!

My home network uses a TP-Link Deco X60 mesh system, very stable. When doing the setup, I was standing right next to one of the mesh node, which measured about 300Mbps download/upload. Basically, I plugged in the Beryl, found its indicator light flashing slowly in blue, found its default wifi SSIDs (one 2.4G, one 5G) on my iPhone’s wifi list, chose the 2.4G one to connect, then was able to open and login to Beryl’s Admin webpage on my iPhone, chose “Repeater” mode, was able to scan the nearby wifi networks, was able to see my home wifi SSIDs (one 2.4G, one 5G) listed on the webpage, chose the 2.4G one, entered my home wifi password, trying to join home wifi, and failed to join after 10 seconds or so. I found myself still on the “join” page and the banner on top that indicates wifi not connected was still showing up. I repeated this process many many times, all with the same result. (I also disconnected the home wifi connection on my iPhone and set it to NOT auto-join, to not interrupt the setup process)

Also wondering - The Beryl’s indicator light on the device kept flashing slowly, all the time during this process. Is that expected? The manual doesn’t explain this clearly.

Note: I also tried the Cable connection, i.e., wired the Beryl to one of my mesh node, then I found it working in this way, but the WiFi speed it provided was only about 50mbps download and 30mbps upload, much slower than what the mesh node provides via WiFi.

I started feeling this Beryl device may be defective. I probably will return it if I do not hear anyone having the same experiences (and better yet with solutions) by this weekend.

Thank you!

This is normal. When beryl does not have Internet, its LED shows like this.

You should use 5G wifi. If you are using 2.4G wifi, the speed is just normal.

Thanks alzhao for answering those two questions! Could you please also share your opinion on the most important question: why can’t the Beryl join my WiFi network as a Repeater?

It arrived with Firmware 3.200, and after the connection failure, I upgraded to Firmware 3.201. That did not help.

The Repeater function is most critical to me, as I plan to use it on travel to improve the WiFi quality. If I cannot get it to work, I will have to send this device back.


I don’t know why it failed. Do you have logs?

Can you try join 5G WiFi or try join other WiFi networks to see if works?

I have the same issue. Beryl 1300 to a TPLink Deco M9 Mesh WIFI network. It does not work. I am on latest firmware. My Slate 750 works just fine, and I tried the B1300 back in March, and it failed then. I was hoping an updated firmware might fix the problem. Sadly no. And no solutions from tech support.

Same here. Bought the Beryl to replace my Slate, but cannot connect to my Home Router whereas Slate can. Not any FW is working, gonna bring back that piece of crap.

Same here. New Beryl with actual firmware. Not working as a repeater.
Will sent it back

This thread is talking about Beryl MT1300.

For Beryl AX MT3000, pls upgrade firmware to 4.2.0 GL.iNet download center