Help configuring new GL-MT2500 in my home network

I’ve made a very simple diagram to illustrate my home network:

Before introducing the Brume2, My Asus router was the main gateway, and I had a raspberry pi running a wireguard server with the two profiles in the diagram. Now that I have the Brume2, I would like this to replace it and it’s functionality. However, I am having difficulty configuring everything to suit my needs.

for one, it appears the Brume2 can’t even ping(using the network diagnostics UI in luci) the Asus, either on (the assigned ip from the Brume2’s DHCP server) or the gateway ip. I’ve tried adding static routes in the luci advanced config of the brume2, but nothing worked.

Is having two routers (and two DHCP servers) just not a good idea? My limited networking knowledge tells me this should be possible, but maybe I’m just making things more difficult for myself.

Ultimately, the goal is for all 4 subnets to be able to communicate with each other as if they were all a single LAN, but for now, I can’t even get the first two pieces to talk to each other.

Thanks in advance!

You have explained your use of the GL.iNET but the question that remains is what would you use the Asus for? I have a similar setup but put my Asus in AP (access point) mode and avoided all problems with double NATing…etc. Another less stable solution would be to keep the Asus as your main gateway and use the GL.iNET in Drop-in Gateway mode behind the Asus.

The Asus is a wireless router so it provides wireless access for all the home devices, as well as wired connections to all my other devices in my network, including my servers.

Go for putting it in AP mode then and you are sorted.

1 Like

Given the routers that you already have, I agree with @Almahadeus to set up the Asus as an access point.

Although the Asus RT-AC68U is a nice router, it is getting a bit long in the tooth.

I do not work for and I do not have formal association with GL.iNet.

1 Like

well I was really hoping that I wouldn’t have to completely redo all my static ips on the LAN, and it looks as though the brume 2 doesn’t have the GUI options to do it in the main configuration, guess it has to be done though luci.

I suppose if this is the only option I have no choice.

Do it once properly and then back it all up like this:

well it’s still not working. I can connect to the wireguard server and ping devices on the lan but I guess I’m missing some additional configuration because both internet and local device http interfaces are not working. I can’t access the MT2500 admin page even though I can ping the IP successfully.

GL-MT2500 VPN dashboard:

I’m using a Creta (GL-AR750) as the wireguard client:

I’ve connected my laptop to the ethernet on the creta to test, while the creta is using the repeater functionality to get internet from my cell phone hotspot. So the devices are on separate internet providers in order to test the tunnel.

In the scenario from the original diagram in the thread, I am trying to set up Profile1. Haven’t even gotten to trying Profile2 yet.

Based on what you have provided, you should be able to access the http interfaces. I don’t know why you cannot.
You cannot access

BTW, except for setting MT2500 as Gateway/DHCP server and Asus as AP, you can actually just connect MT2500 to your Asus as one client, then set up port forward from your Asus to MT2500 wireguard server.

1 Like

Instead of going through the WireGuard client on your Creta router, can you do a test using a (free) WireGuard client on your laptop to connect to the WireGuard server directly and try accessing the GL-MT2500 admin page?

With a WireGuard client on my laptop, I can access the admin page of my GL-MT2500 at its 192.168.x.y LAN IP address. If this works for you also, then the issue only relates to going through the Creta.

I don’t quite know what the problem is, but it happens with profile2 as well. Looking at chrome devtools gives a little more insight as to what is happening, but I don’t have any explanation for why it’s happening:

This is for the main javascript file request