(Help) GL-AR300M16 Disables 2.4ghz Wi-Fi signal

Hello users, I am having a problem with my GL-AR300M16 travel router. I set it up in repeater mode and it will work for anywhere from 1 to 20 minutes and then it will completely disable my 2.4ghz signal on my routers (I’ve tried 2) however the 5ghz on my one dualband will continue to work.

When I first got it I had trouble with it just completely disappearing and going completely offline (the ssid would be gone) so I did soft and hard resets and it would work fine for a few minutes then would go offline again. Eventually, it stopped working altogether and was essentially a brick. I re-flashed the firmware with uboot and it started working but now has the Title problem.

Now, this could completely be user error on my part and any help is appreciated.

Here’s some info on the settings and other things:

Model: Gl-AR300M16
Firmware: 2.27 (After uboot flash. Not sure what was originally on it)

Repeater set in WISP mode

Wireless Settings:
Mode - 300M (11g) (tried other settings too)
Channel - 10
SSID - travrout
Encryption - WPA2 & WPA/WPA2 Mixed (Tried both)
Password - tried with and without

Radio Settings 2G:
Mode - 11g (54M)
Channel - 10
Power - 20

AP 2G:
SSID - travrout
Encryption - psk
WDS - 1

Routers I’ve connected with:
Asus RT-AC66U
Linksys WRT54G

Some additional info:

When ever the AR300M disables my 2.4ghz channel the red light on the AR300M will go solid red and stay that way and the only thing that will get the router working again is a hard reset.

Why do you set it to WDS mode? In this case, the router had disabled dhcp server.

I have it set to WISP are you saying I should set it to WDS? Sorry I’m new to using a repeater.

I see there.

If you have set it to WISP mode, you’re correct. As you said, you have to hard reset when you disable the AP, right? In this case, do you mean you can’t get IP address when you attach the cable to the router?

I have to hard reset once it disables my 2.4ghz channel(I also have to reboot my main router). Setting it up as a repeater won’t work again until it’s hard reset. I’m not sure what you mean on the second part about obtaining an IP. I can get an IP connecting to the AR300M but I cannot get an IP when I try to connect any device to my main router. Any device I try to connect to my main router with will try to obtain an IP address then it will give me an authentication error and then will connect to my 5ghz channel since it is saved on the devices. If I don’t have my 5ghz channel saved on the device it will sit in an authentication error on my 2.4ghz channel.

Any ideas? Is this faulty equipment? I have been trying different things to no avail. I am still looking for any answers. Thank you.

Maybe you can just post the content of you /etc/config/wireless so that we know your setting exactly. Remember removing your key.

One strange thing is that you said: the AR300M16 disables your main router’s WiFi. I wonder if this is even possible. When in WISP mode and if it cannot connect to your main router, it could disable itself. But no way it will disable your main router.

Can you also give a screenshot of the Internet status page of AR300M16 when you connect to WISP successfully? I want to check what is the IP address it got from the main router.