Help installing OpenWrt on GL-B2200 Velica

I’m trying to install OpenWrt on GL-B2200 Velica.

Using the information here and here, I’ve got to uBoot (uboot2.0 v20.10.14).
I gunzip the OpenWrt emmc firmware found here, then select the file in uBoot and click ‘Update firmware’.

The install starts, reboots, then the top light on the router (the smaller of the two) alternates flashing between blue and white a few times, then turns solid blue. It doesn’t progress any further, no matter how long I leave it and no matter how many times I try.

I’ve tried waiting three minutes (as suggested), and have left it 24 hours. I’ve tried several firmware versions from the OpenWrt website.

I can’t access it from or when the light is blue.
Ping: Destination Host Unreachable
I have to do a reset to uBoot.

Any tips would be very welcome!

Looking at the git commit;a=commit;h=febc2b831f633d8d6648267952bd43c35689c36f

I’d recommend installing Openwrt 22.03 and seeing if that boots, the instructions on the git commit aren’t great.

1 Like

Thank you. I should’ve mentioned I already saw the git commit, and followed the instructions there.
I’ve tried 22.03.0 in addition to six others plus the latest three (and the snapshot).
I’m totally baffled. I’ve trawled through hundreds of search engine results and nobody else has posted about this issue.


I have two Netgear Orbi Pro that has nearly identical hardware but a dual partition layout that either boots partition 0 or partition 1.;a=commit;h=2cb24b3f3cd89692f3c0bd137f3f560ada359bfa

Can you get into telnet in the stock firmware, as if you actually have a dual boot that is forever booting from the second partition and Openwrt will only boot from the first partition you may actually be successfully installed but booting incorrectly.

It may be worth posting over on the Openwrt forums regarding this.

I’ve spent a few hours investigating, and can’t see anything to suggest there are multiple boot partitions.
The git commit instructions don’t help, so I’m wondering if they’re out of date. I’ve seen people recently saying they’ve managed to get OpenWrt working on Velica, so maybe this is a hardware issue. I’ve tried on six units, none have flashed properly.

Unzip openwrt-23.05.3-ipq40xx-generic-glinet_gl-b2200-squashfs-emmc.img.gz and extract openwrt-23.05.3-ipq40xx-generic-glinet_gl-b2200-squashfs-emmc.img.
If you uBoot it, you should be able to use Openwrt.

Will try when both my Velica arrive today, also built the new uboot that's available.

Have you had any luck getting it to work?