Help needed with Brume (GL-MV1000), Asus router and Wireguard

Hello folks,

I just bought the Brume and I love how it comes with everything I need out of the box. However, I am having such a hard time getting it to work and use Wireguard VPN.

Goal: Activate Wireguard on my Win8 machine to gain access to my home network and files on my synology diskstation. I need access to my files when travelling.
Hardware: Brume (GL-MV1000) & Asus RT-AC1750 & Alfa AWUS036ACS Wireless Network Adapter (in case I need it)

What I have tried: plug in the WAN from the ISP into Brume. Use the Brume white LAN Cable and plug it into the Brume LAN slot and connect it to the Asus router WAN port. It didn’t work so I tried Brume LAN to Asus LAN. Either way, what is the correct way of doing it?

I have set up the Wireguard server and I am able to connect to it using my iPhone and Win8 PC. On the PC, after I activate Wireguard client, I get my home IP but I don’t have any access to internet. What am I doing wrong? How do I troubleshoot this? Do I need anything extra?

I also tried changing the Network mode from router to access point/bridge. It’s just driving me insane and I would like to get it to work instead of returning it.

Can someone please outline some simple steps on how to get it running? Please help.

Thank you,
C

Well there are a couple of ways to get you up and running with your setup. Synology is able to run wireguard, but its extremely beta and you need to compile a lot of things, not user friendly, everything is manual.

Second thing you can do is as you already did, but you missed a step. You want to run Brume in router mode. Then you want to go into your Asus and change it to just AP, Access Point. Brume should be handling the IP addresses. If you don’t change the router mode in your Asus, IP’s from your Brume will not be served to devices connected, and things just won’t work as you want.

Apart from that your connections were correct. ISP -> Brume WAN, Brume LAN -> Asus WAN.
Brume as router, Asus as AP.

1 Like

Pls do as @Johnex said and it should solve your issue.