Help setting up port forwarding - not working

So I’m trying to set up a site to site VPN network in my home network so I can access it abroad, bought two GL iNet routers and started to set it up to realize my ISP (T-Mobile Home Internet) doesn’t support port forwarding and I went over to Spectrum and switched, so I finally have the ISP and routers but in the process I was unable to open up the port 51820 (for Wireguard), I’ve tried following the instructions from multiple sources and have set up a number of rules trying to open it up with no luck, I’m a begineer with networking so sorry if it’s something really obvious but I’ve leave my configurations screenshots below for more information, if something else is also needed for assistance please let me know

Okay, let’s get a little ‘quick & dirty’. In order of increasing complexity:

  • Can you set your ISP modem to be just that, a modem?
    • Look for an option in its Web GUI (presuming it has one) & toggle ‘bridging’ on.
  • Can you find a feature in your ISP modem Web GUI for a ‘DMZ’?
    • Put your preferred GL device IP on it.
      • It will then act as the router for your entire LAN/internal network.

Port Forwarding has to be set up on the Spectrum ISP router to forward traffic over to the GL.iNet WAN IP address.

If you do not want to set up Port Forwarding, then you can probably “bridge” the Spectrum ISP router as a modem only.

I do not work for and I do not have formal association with GL.iNet