Help! Stuck with Luci! Want WebAdmin. How?

I tried to upgrade software on MT300N-V2 and ended up bricking it. GLI sent me instructions for debricking
https://docs.gl-inet.com/en/3/troubleshooting/debrick/
and that worked. However,it wasn’t clear from their instructions whether to install the lede-mt300n-v2-clean-2.264.bin or the gl-mt300n-v2-3.0-1011_clean.bin versions. I tried the latter and it came up as 192.168.1.1 instead of 192.168.8.1 and in Luci. I could not get the WebAdmin at either location. I changed the router address to 192.168.8.1 using Luci and Luci comes up at this address but still no WebAdmin.

I then watched the video and noticed the video suggested the 2.264 version (probably because it was an older video) but decided to try it. It also came up with Luci and no WebAdmin. So I went back to the 3.0-1011 version.

So now I am stuck with Luci. But configuring it is too complicated so I’d like the simpler WebAdmin. How do I get that to come up?

Note, I connect with my Linux computer and know linux and can do ssh if there is a configuration change that needs to be put into a file or files but for the life of me, I can’t figure out what needs to be changed to make WebAdmin come up.

Help!

You should follow the debrick guide again but use the latest firmware:

https://dl.gl-inet.com/firmware/mt300n-v2/testing/

openwrt-mt300n-v2-3.104.bin

You have made it much worse for me. I did what you suggested, and did the following:
Disconnected ethernet and power.
Held down reset and then inserted power cable.
After the flashing, power light came on
Set linux machine to add 192.168.1.2/24
Connected to router.
No connection at either 192.168.1.1 or 192.168.8.1 works
“Activation of network fails” message on my computer.

The router doesn’t do anything. Not Luci, not debrick.

When you flashed the “clean” version you flashed Vanilla OpenWRT without the GL UI. You should try the instructions again, as that is the correct way to get the firmware flashed after changing type.

The network cable should be inserted before you put power to the router btw as step 2 of the debrick guide.

I tried it a couple more times and got it up. Thanks. I am now running on the 104 software and I have the WebAdmin running.

Unfortunately, I am no better than where I was when I tried to update and bricked it.

The router works. However, when I try to activate the VPN, the router most of the time will disconnect from the server and I will no longer have internet. Usually, it will reconnect but by then the VPN has gotten an “unreachable” message. Other times I have to do a rescan to get it to connect. Then if I try turning on the VPN, it disconnects again. Once in a while, it will work and will stay connected to the internet.
I have to go back and forth between trying to turn on the VPN and reconnecting the router to the internet until I get lucky.
Should this be considered a separate topic?

Yes, put it in a different topic and mark this one as solved :slight_smile:

@jpezz

Just for future reference if you have to uboot recover again, this is what works for me :

  1. Remove power cable
  2. Insert LAN cable into LAN port
  3. Hold down reset button and keep held down
  4. Insert Power cable
  5. The power (left) light will come on solid
  6. The Wifi (right) light will flash 5 times
  7. When you have the power (left) and activity (middle ) lights solid release the reset button
  8. You should now be in uboot mode (192.168.1.1)

I find the gl.inet instructions a bit ambiguous :slight_smile:

Hope this helps.