Help with router setting

I got a new mt3000 and got it all set up for Openvpn server on my house network. I just can’t get Openvpn clients to connect to the server. Keep getting timeout error. Please help. Error log below

Nov 28, 2023, 17:09:30] Connecting to []:1194 ( via UDP

[Nov 28, 2023, 17:09:40] Server poll timeout, trying next remote entry…

[Nov 28, 2023, 17:09:40] EVENT: RECONNECTING

[Nov 28, 2023, 17:09:40] EVENT: RESOLVE

[Nov 28, 2023, 17:09:40] Contacting via UDP

[Nov 28, 2023, 17:09:40] EVENT: WAIT

[Nov 28, 2023, 17:09:40] Connecting to []:1194 ( via UDP

[Nov 28, 2023, 17:09:50] Server poll timeout, trying next remote entry…

[Nov 28, 2023, 17:09:50] EVENT: RECONNECTING

[Nov 28, 2023, 17:09:50] EVENT: RESOLVE

[Nov 28, 2023, 17:09:50] Contacting via UDP

[Nov 28, 2023, 17:09:50] EVENT: WAIT

[Nov 28, 2023, 17:09:50] Connecting to []:1194 ( via UDP

[Nov 28, 2023, 17:10:00] EVENT: CONNECTION_TIMEOUT [ERR]

[Nov 28, 2023, 17:10:00] EVENT: DISCONNECTED

[Nov 28, 2023, 17:10:00] EVENT: CORE_THREAD_DONE

[Nov 28, 2023, 17:10:00] EVENT: DISCONNECT_PENDING[quote=“discobot, post:1, topic:35615, full:true”]


the log tells us that the server isn’t reachable. Are you using any other router?

From which device do you test? Mostly you can only test from outside the network.

In addition you should think about using DDNS instead of IP and maybe wireguard instead of OVPN.

Are you sure you can reach your home network from outside?
Many ISPs use Carrier Grade NAT and/or block incoming connections entirely.

Is that IP you are using the same as the WAN IP in your router interface and does it match what sites like report when you access them from your home network?

Thanks for the help. Here is my hardware config and ISP:

Spectrum Modem Router model: Spectrum D3.1 eMTA DOCSIS 3.1 Advanced Voice Modem

ISP: Spectrum


When I run a DDNS Test, the system is giving error below:

“The IP from DDNS domain resolution is not the same as the WAN IPs of the device. You need an Internet Public IP address to use the Dynamic DNS . If this router is behind NAT, you may need to set up port forward in your ISP router. If you have VPN Client enabled, please disabled “Services from GL.” shows that I have a Public IP address which is not the same as my WAN IP. It sounds like I need to set port forwarding in my Spectrum router. I tried several different ways to login to the router and could not succeed. Any advise?

Note: I have no problem logging into my GL.inet travel router admin page.

Sorry for this late, you shall set the port forwarding rules on your spectrum router to get the vpn server settings work.
If you are not so familiar with it, could you please kindly reach us in this link and our technical guys shall help with it.