Hi, is the option "only allow the following use VPN" apply to domain/IP?

there just 3 website that are banned in my homeland,
and i ONLY wanted to access these 3 with VPN, leaving other internet activities normal.

What i tried, is not working, these 3 sites indeed i cant go after config as below:

  1. internetl kill switch enabled
  2. config as above, with the 3 sites added at the bottome.

ofcause, aplpied, rebooted.

thanks

What is your device model and firmware version?
Did you remove the prefix https:// when you set the domain name?
If you run tracert [domainUseVPN] from a terminal on the client, what does it show? Does it go through your VPN server.

mine is brume, version have to check later.

so for 2. should the https present or NOT present?

  1. how to run? from windows’s command prompt?

thx

It should not present https://

Yes

1 Like

hi,

  1. mine is brume w100, firmware: 3.216
    image

  2. how about the www.xyz.com
    when i enter, should i only type “xyz.com”?
    please state clearly, please dont only type yes or no thx.

  3. in win10 command prompt, even with admin right,
    no luck:
    image

btw, please let me state, that for this several years i am with gl inet’s router, the vpn policy/kill switch is the troublesome part, they seldom worked as expected out of the box.

thanks

let me state clear:
now USA banned me from using a website called www.abc.com

(everyone know what site i am refering to indeep)

if i 24x7 use VPN to use USA IP, when i connect to hongkong’s ebank, i’ll be screwed, sometimes they even immediately cut my credit card etc.

my wish:

  1. i wish i am indeep 24x7 using hong kong IP and only use USA ip for abc.com, but obviously abc.com may knew i am using hong kong IP if any of their action use other domain e.g. they forward access to other website.

  2. how about this,
    i always use USA IP, then i only use hongkong IP for my hong kong ebank.
    in this way if my hong kong ebank detect problem, i
    can easily go down street in 5mins with a knife and some gasoline.

so i think what i am trying to use the vpn policy is for solution 2, but didn’t work.

my setting:

  1. in OpenVPN Client, i am connect to US server
  2. Internet Kill Switch is set to Enable, so that if VPN dropped, line cuts, abc.com wond get my HK ip
  3. VPN policies.
    this is supposed to only use HK IP for hangseng.com and whatismyip.com

but in reality, is that
a. https://whatismyipaddress.com/ (another IP checking website) detect USA IP
b. https://www.whatismyip.com/ gives a black blank screen:

無法連上這個網站

請檢查 www.whatismyip.com 中是否有錯字。

  • 如果拼字正確,[請嘗試執行 Windows 網路診斷](javascript:diagnoseErrors())。

DNS_PROBE_FINISHED_NXDOMAIN
c. hangseng.com also this black blank screen.

obviously the 2 websites didn’t connect.
please help

I think you should type xyz.com. It contains www.xyz.com.
www.xyz.com is a subdomain of xyz.com.

Sorry, I wasn’t clear, you should replace [domianUseVPN] with the domain you want to use the VPN with, e.g. abc.com.

It looks like both the VPN client and the VPN policy are working properly.
Can you try turning off Kill Swtich? The site will use some requests outside of its own domain. It looks like the connection is blocked without using VPN.

1 Like

but if the internet kill switch is off,
i risk that abc.com may know my real ip if they forward me to some other services?

ok, you are correct.

  1. if kill switch = off, everything i want to “solution 2” happends i.e. ipchecker1 detected hk ip, ipchecker2 detected usa ip

but

I now risk abc.com know my IP if the vpn is unstable.

thanks

btw, i use nordvpn,
if that may provide additional help.
thx

If you want to enable Kill Swtich at the same time, you have to know all the sites requested with or without VPN (depending on which rule you use) and add them to the list.
You can press Ctrl + Shift + I before visiting the site, then visit the site and check the Network tab, which will list all requests by the site.