High latency with flint


I have a flint on 4.2.0 and my Xbox is hardwired in to the router. My internet package is 400 down 80 up. Network statistics show very high latency on the Xbox both wired and on Wi-Fi.

Is there any known issue with this router or firmware that could cause such a problem?

What functions do you use? Adguard and dnscrypt could introduce a little DNS query latency.
How about ping and speedtest.net result with another device connected to flint?

@hansome Could also be down to using Wireless and the buffer bloating in that. Noticed on Kenerl 4.4.60 myself that using wireless be it 2.4Ghz or 5Ghz tends to suffer from it.

Doesn’t seem to be a major issue though on 5.15 :wink:

I stripped the router back to factory and tried and saw the same thing. It’s only an issue on Xbox. I’m hardwired in. Tried another router and it exists still so it’s not router specific at this point. Must be the latency to the Xbox servers - tried it wireless too and get the same thing. Version 5 you say?

No kernel 5.15 personal project.

Thank you for the information. Is it the WiFi driver or the kernel version that is causing the buffer bloat?

On my 5.15 kernel build I am using the same firmware blobs as your sdk version on 4.4.60 kernel but the driver is open source (openwrt native)

1 Like