Hostname to send when requesting DHCP not working

Have an GL-AR750S firmware version 3.025, I would like to use the feature “Hostname to send when requesting DHCP”. When I check the DHCP server the GL-AR750S is grabbing an IP from, another router, hostname is always GL-AR750S. It does not honor this field. Anyone have an idea of how to force this.



Hi, It’s a firmware issue. And it will be fixed in latest firmware.

1 Like

Thanks for the update!

I just updated to the latest firmware 3.100 , unfortunately this feature still not working. Anyone know of a work around?

I just tried 3.100 and it works.

You have to disconnect your repeater and connect it again so that the name will be sent.

I tried your suggestion, disconnected repeater and reconnected, same result. I rebooted my primary wireless router, and rebooted the GL-AR750S, still sends the name as "GL-AR750S as the client ID. Here is a screenshot of primary wireless router’s dhcp lease pool, a Netgear NightHawk 9600;

I am pretty sure the Netgear is not the issue, as I have a TP-Link travel router that performs this same function, and what ever name I assign the TP-Link repeater shows up on the Netgear.

Not sure if this matters, but all my GL-AR750s clients connect on 5GHZ, the 2.4GHZ radio is only being used to connect the GL-AR750s to the Netgear in repeater mode.

Looking at the network config file shows me the value from the GUI is being saved correctly, so where is it getting the name GL-AR70s from? It must be specified somewhere else I am not seeing.

Is it cached by the main router?

If you have another router you can try to connect it to wirelessly to find out.

I did try to connect wirelessly to another router, and it forwarded the name correctly on different router. So there is something up with the upstream Netgear Nighthawk R9‬600. Even after rebooting the Netgear R9‬600 while the GL-AR750s is disconnected, it still holds this name, after reconnect. Can’t figure out how to clear. So issues does appear to be with upstream Netgear router.

Thanks for helping me out in troubleshooting steps!