How are you guys testing disk speed?

I’m not sure what I’m doing wrong but DD is not providing the speed when I run the commands. :slight_smile:

root@GL-AXT1800:/tmp/mountd/disk2_part1# sync; dd if=/dev/zero of=tempfile bs=1M count=1024; sync
1024+0 records in
1024+0 records out
root@GL-AXT1800:/tmp/mountd/disk2_part1# dd if=tempfile of=/dev/null bs=1M count=1024
1024+0 records in
1024+0 records out

Oh, maybe I should use HDPARM instead. I installed it using the following commands:

opkg update
opkg install hdparm

And then I ran, from the SD Card mount directory, on an existing testfile I created with dd above:

hdparm -t testfile

The output seems very reasonable for a Sandisk card with a maximum rated performance of 120 MB/s:

 Timing buffered disk reads: 226 MB in  3.01 seconds =  75.06 MB/sec

Disk Read/Write speeds with Windows 10 PC over 1Gbps Ethernet to router LAN:

  1. SD card is ADATA 32GB Class 10 (slow writes)
  2. USB drive is Kingston DT microDuo 32GB USB 3.0 (slow writes)
  3. Hard drive is Seagate Momentus 7200.4 500GB spinning hard drive in USB 3.0 enclosure
  4. SSD drive is Intel SSD 330 Series180GB in USB 3.0 enclosure

Speeds were calculated by timing the copying of a 3GB file for SD/USB drives and a 5GB file for Hard drive/SSD
Strange that Hard drive Read is only 32.5MB/sec, but I ran the test twice.
Router USB 3.0 port has enough power for the spinning hard drive.
SSD performance is impressive!

For comparison, here are Disk Read/Write speeds when plugged directly into with Windows 10 PC USB 3.0 port:

Strange that SD card Write is only 12MB/sec, which could be the SD card reader/writer is slow.

I do not work for and I do not have formal association with GL.iNet

1 Like