How long does uboot takes to update firmware in ax1800?

How to verify that uboot process is complete on the ax1800 flint router?

What should be light color after its done?

I have been waiting for approx 30 minutes. And the light is blueish solid.

When you upload the uboot, it will finish quite fast, less than 1 minutes. Then the router will reboot.

Maybe your router is bricked.

What are the symptoms of being bricked ax1800?

Just power cycle the router to see if it boot normally.

Then try uboot again to see if you can enter uboot UI. If you can, pls flash the firmware again.

Otherwise it is over.

I can access to uboot, and used recent img now blue light is flashing.

Should i run a power cycle or should i wait little more?

It takes two or three minutes and boot normally.

Any other way to recover ax1800?
Other than uboot?

But as you can use uboot, it should work fine. If not, maybe worth to have a further check.

Maybe try a different browser?

Can you describe the LED status? Flashing mean quickly? Slowly? Like breathing?

its fixed now.

tried after sometime.

does router saves some data in cache/ram?

Everything should be cleared when doing a power cycle.