How make Guest Wifi have internet?


#1

I have GL v3 router.

Connect to modem with Wifi.

Have Wifi Guest network.

Have laptop connects to Guest network and have 192.168.9.x IP.

But laptop no having internet.

Also laptop no can go to 192.168.9.1 in browser.

Please explain what I must check. Thank you.


#2

It should have Internet by default. I am not sure what is wrong. Can you make sure the subnet is not the same as upstream router?

It is it allowed to access the router UI.


#3

@alzhao

It should have Internet by default.

Yes. But does not have.

I am not sure what is wrong.

Also me.

Can you make sure the subnet is not the same as upstream router?

Yes I make sure. Subnet is 192.168.9.x but upstream router is 192.168.120.x.

It is it allowed to access the router UI.

Laptop connects to Guest wireless on GL but go to 192.168.9.1 in browser is not possible.

I do not create Guest network by use GL UI. I use Luci because no one tell me how I can create in GL UI but I ask so many times where is “Repeater section” in GL UI that is say in doc.

I know is not problem with connection because LAN wire port on GL router have 192.168.8.x and this have internet. Only wlan1 no have internet.


#4

If you do this manually in luci you need to take care of the firewall as well.

You can try latest testing firmware from us and you can enable guest WiFi by one click.


#5

@alzhao

You say this

You can try latest testing firmware from us and you can enable guest WiFi by one click.

I already tell you I am use latest firmware! Now I ask for number one million time where is this click? I NO SEE “Repeater section” like say in doc. I tell you this so many times.

If you do this manually in luci you need to take care of the firewall as well.

Okay if you say then I will do. Please explain. I prefer use GL UI but need same informations I asking you for two weeks!


#6

@alzhao Is this helping?


#7

Connect to guest network, you only can access the Internet, you can’t access all resource of the router, such as web, ftp and so on.

I just tested for myself, the guest network can access the Internet. Could you please show the firewall configuration file here?

You can ssh to the router, and execute cat /etc/config/firewall.


#8

@kyson-lok

I just tested for myself, the guest network can access the Internet.

But you are create guest network by use GL UI? Me no. I want do this but no one telling me how I can do. Everyone only give me link to doc and doc only say must go “Repeater section” but not exists for me.

Okay I including firewall.zip
firewall.zip (992 Bytes)

Thank you.


#9
  1. YOU NO SEE “repeater section” because you are already connected as repeater!
  2. Guest networks are configurable in Wireless section - do you see that?

Glitch
PS. feel free to ignore my advice for two weeks before trying it!


#10

@glitch

YOU NO SEE “repeater section” because you are already connected as repeater!

This not true. I think you only read some words I writing. I no have repeater. Have wireless network but not has internet. Why I need explain so many time you? I think is because you not want help only want argueing.


#11

@kyson-lok You receive when I send firewall? I send again different way now:


config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6 MyNetwork wwan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'
	option reload '1'

config rule 'glservice_rule'
	option name 'glservice'
	option dest_port '83'
	option proto 'tcp udp'
	option src 'wan'
	option target 'ACCEPT'
	option enabled '0'

config zone 'guestzone'
	option name 'guestzone'
	option network 'guest'
	option forward 'REJECT'
	option output 'ACCEPT'
	option input 'REJECT'

config rule 'guestzone_dhcp'
	option name 'guestzone_DHCP'
	option src 'guestzone'
	option target 'ACCEPT'
	option proto 'udp'
	option dest_port '67-68'

config rule 'guestzone_dns'
	option name 'guestzone_DNS'
	option src 'guestzone'
	option target 'ACCEPT'
	option proto 'tcp udp'
	option dest_port '53'

config include 'glfw'
	option type 'script'
	option path '/usr/bin/glfw.sh'
	option reload '1'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

config include 'shadowsocks'
	option type 'script'
	option path '/var/etc/shadowsocks.include'
	option reload '1'

config forwarding 'forwarding_origin'
	option src 'lan'
	option dest 'wan'
	option enabled '0'

config forwarding 'guestzone_fwd'
	option src 'guestzone'
	option dest 'wan'

config include 'glqos'
	option type 'script'
	option path '/usr/sbin/glqos.sh'
	option reload '1'

config include 'mwan3'
	option type 'script'
	option path '/var/etc/mwan3.include'
	option reload '1'

config zone 'vpn_zone'
	option name 'ovpn'
	option input 'ACCEPT'
	option forward 'REJECT'
	option output 'ACCEPT'
	option network 'ovpn'
	option masq '1'
	option mtu_fix '1'

config forwarding 'forwarding_vpn1'
	option dest 'ovpn'
	option src 'lan'



#12

I said latest TESTING firmware. Did you download and flash manually?


#13

@alzhao

3.013 is latest “TESTING firmware” and I have this now two weeks. You see when I post screenshot?

I go “Wireless” tab and is blank 100%, no says anything.

I go “Internet” I can make wifi connect for modem. But not create guest network.

I go Luci I can make client wifi to modem. Also I can make guest wifi for laptop. But guest wifi for laptop no have internet. I try delete and do again with GL UI also Luci. Always same.

I try anythings you says. Please explain what I must do and I do.


#14

You are right - I give up on you as I think it’s a lost cause.


#15

clear browser cache and try again.

You can also try another browser, or private browsing mode.


#16

@alzhao

I already say many time I use many different laptop for connecting. Problem not my. Problem is GL router config. I already send firewall to @kyson-lok. Existing answers inside? What you want me trying and I trying.


#17

Did you run OpenVPN? I check the firewall configuration file, it seems you had started OpenVPN, so it missing a forward rule.

config forwarding
	option dest 'ovpn'
	option src 'guestzone'

Not sure what you had done, if you can reset the router to factory settings, and then do again. Please document each step and place them to here, it would be help.


#18

@kyson-lok

config forwarding
	option dest 'ovpn'
	option src 'guestzone'

YES!!! WORKING!!! THANK YOU!!!

I have working now but you must know GL UI continue have many troubles. I do reset the router to factory settings but every problems is same. If I make WiFi client to connecting modem I will not see no options for WIRELESS, nothings completely only white page does not say nothings.

After I do this to /etc/config/firewall like you are saying and now I am see 2.4G WiFi where I click WIRELESS so I think maybe you have problems in GL UI because it not support WISP configurations if using OpenVPN.


#19

Could you please record a video about it?


#20

I think I can not. How I can do this? Also why is how I explaining not helping? I think you are thinking there existing something I not saying.