How to access local LAN network on Wireguard?

I read multiple posts here about access to the local LAN from VPN, and different posts suggest different solutions, but nothing worked for me.

I have the most basic Wiregaurd VPN server setup and running at home with default settings, so it should be really simple for me, yet it isn’t.

I can VPN into my home router and get the internet IP address of the router, so the VPN works for the WAN part. I just don’t understand the basics on how to use the VPN to access my other home devices on the router LAN. My router is Brume.

The Wireguard server setup is, which is the default given. I have “Access to Local Network“ checked. When I VPN in, I can reach the router itself using or

But I don’t know how I access my other devices connected to the router. For example, I have another device on the LAN with local IP (it happens to be another GL router, but I don’t think it matters what it is) and I cannot reach it. Ping to times out, and times out as well.

What I tried based on some posts here:
This post suggested to insert an additional wgserver zone rule, which I tried but it just killed the WAN on my router altogether, even after I undid the change, and I had to revert the firmware to fix that mess. Maybe the zone config is specific for each router/firmware, and the thread was for a different router.
• There was another advice to setup a port forward from the wireguard zone to lan zone, e.g. forward 8080 wireguard zone to 80 lan zone, and still times out.

I’m not advanced with networking, so I’m looking for a straightforward set of instructions/tutorial, that will work for my router (Brume, firmware 3.2xx). Please help.

UPDATE: I also setup the OpenVPN server on the router, and I can access the local device at using OpenVPN without any additional configuration. So the above problem is only with the Wireguard server.

Be sure there are not any route conflicts.
You can try to change wireguard subnet to

Don’t you have to add device ip’s you want access to the list in wire guard? Just a haphazard guess as I don’t do vpn’s (if anyone wants to hack my network :joy:)

The only other thing I can think of would be to add them to the host names list or static routes?

My allowed IP’s are set to AllowedIPs =, ::/0. Doesn’t it mean all IPs allowed?

Here is my client config file, redacted:

PrivateKey = …
ListenPort = 43430
Address =

PublicKey = …
AllowedIPs =, ::/0
Endpoint = …:51820
PersistentKeepalive = 25

I think you solved it. My other local device was a secondary GL router where I also had the Wireguard server turned on with the same IP range of as the parent router Wireguard. Even though I had no clients connecting to that secondary router, I guess it created a conflict. As soon as turned the Wiregaurd server off on the secondary router, I could access it from the VPN of the parent router. So the lesson here, if you run VPN on multiple routers, make sure to define unique IP ranges to avoid conflicts later on.