How to add IPSEC/L2TP support?

Hello,

Many months later, new firmware update…any update for preshared keys on L2TP or IPSec ?

Thank you very much !

1 Like

@Caryl, it is a shame that I haven’t get this working. Will push our dev team for this.

Thank you very much.
I look forward to this update.
In the meantime with optical fiber the bit rate on the MT300A with openvpn is much too low. I tried everything to get at least 20 Mo/S but nothing: softether, deletion of the encryption on openvpn… I still have the L2TP….

For information, in order to get the TV in 4K we need to reach at least 15 MB/S and I think many will ask you the question or look for this possibility.

Thank you in advance for this update. If not, could you recommend a topic on your forum to increase performance? Which router should I buy from GLI to get these speeds?

A few tips to increase performance would be welcome… you might want to open a special topic for that.

See you soon.

@Caryl

15MB/s is 120Mb/s (not counting overheads) and the wan ethernet port is only 100Mb/s.

I think you need something very much more powerful and with gigabit ethernet to your fibre router/bridge.

Is l2tp/ipsec with pre shared keys working yet?

 

 

Thanks.

1 Like

@JustSomeNobody, no. It is not working yet.

Thanks for the update. Fingers crossed for hopefully one day…

 

 

I try to connect to my “Softether Server on my Home PC (Windows 10)”.
I install the firmware 2.27 on my “GL-AR300M” Router and configure the L2TP Client.
The connection does not work, I can not connect to my Softether Server.

I setup the client on my “Samsung S8+” and the connection to the Softether Server work perfect.

Is there a problem in “testing Version 2.27” ??

Please can you check the firmware 2.27 ??

any suggestions… ?!?

Home PC <----- L2tp/ipsec -----> GL-AR300M <-----------> client "n"
Softether
Server

best regards

Is it L2TP via Ipsec? I don’t think it works now. But if only L2TP should work.

The Softether Server ( more Info under https://www.softether.org )

work with L2TP over IPsec Pre Shared Key

This “Software” VPN Server is very fast and also easy to configure.

please can you try to solve the problem and create a new “testing” Firmware??

best regards

I think someone have tested softether on the router and performance is not increased a lot.

IPSec works much better in B1300 because it has hardware acceleration. Will try in this router.

Any News?
Are you work on the issue “L2TP over IPsec Pre Shared Key”?
Please can you create a new Test Version?
best regards

Are you working on the issue “L2TP over IPsec Pre Shared Key” for Softether Client function?

No we are not working on IPSec now. But rather we will use Wireguard.

But rather we will use Wireguard…

Ohh that is not so fine… I think for the moment wireguard-Server not runs on a Windows system, it runs only on linux.
Therefore it is better to getting the function “L2TP over IPsec Pre Shared Key” for Softether Client” to run.
I think there are lot of people there are waiting for this function.

Windows PC <----- L2tp/ipsec/Pre Shared Key -----> GL-AR300M <-----------> client "n"
Softether
Server

best regards

why server has to be Windows? On B1300 Wireguard server achieves 100 to 200Mbps which is fast enough.

One more vote for L2TP over IPsec with Pre-shared Key. I need it to connect to a Meraki MX VPN.

EDIT:
Sorry wrong thread - moved over here: how I build a VPN tunnel to Fritzbox 7490?

Hi,

Is there any news on a L2TP Client with pre-shared key /ipsec?
I have a UniFi security gateway running which just provides a VPN tunnel using ipsec on l2tp.
Perhaps some testing firmware ? I would prefere a solution using Luci ui.

Regards

Hi everyone

Glad to find this forum. I was a potential purchaser of one of the travel routers, as I need L2TP with pre-shared key. As it looks like it’s not supported, I’m going to hold off purchasing one of these until it’s ready.

I already have a router that provides an L2TP server and it doesn’t support OpenVPN. I’m also not keen on replacing the router.