How to change BSSID in addition to MAC

I noticed that the MAC address spoofing function in the official firmware is incomplete from a privacy perspective as it leaves the BSSID unchanged. Google and Apple crowd harvest and geolocalize BSSIDs through peoples’ smartphones running their operating systems with default configurations. Could someone please post how to change the BSSID through Luci or some other means? I Hope I don’t have to switch to pure OpenWRT just to support this function. A script that changes the BSSID on a regular basis would seem ideal to prevent Wifi mapping. I don’t think the router MAC is available to scanners. That only seems to matter for hotspots which restrict the number of devices that can be connected with the same SMS code or whatever.

mac address and bssid are basically the same thing.

The problem is that each wifi interface has a mac address. The default mac clone function only change the mac address that is used to connect to upstream network.

If you want to change mac address of each wifi interface, that is possible.

But you have to tell which model you are using.

I am interested in Creta, Shadow and Beryl routers.

These two you can set up in luci without problem.

Beryl driver may not be operate in luci. Need to change in /etc/config/wireless directly.

Shouldn’t the MAC spoofing function in the GL firmware be adapted to change both at the same time in that case?

Could you specify under which menu item in Luci I can find the necessary settings?

Is there a way to rotate BSSIDs on a schedule automatically?

@alzhao I tried changing the MAC of the LAN adapter in Luci, in addition to the WAN adapter which is already changed by the GL firmware, but this also does not change the BSSID. Please advise.

Each router is different. Pls let me know exactly the one you are trying and I need to try by my hand.

I tried with Shadow. Thank you for your assistance!

Shadow use open source wifi driver. So pls go to luci->network->wireless and change the mac of all the wifi interfaces.

I tried but there is no editable field for the MAC address under network > wireless > edit. Please check for yourself. I am using the current firmware version 3.211.

I checked XE300 and I cannot find anywhere to set the mac. No idea what is wrong with luc.

Here is what you can do.

SSH to the router (or just use winscp) to edit /etc/config/wireless and add like below

image

Then restart wifi or just reboot the router