How to configure a USB ethernet adapter as LAN?

I am using GL-AX1800 on the latest v4.2.1r4.
I have plugged-in the USB adapter, it could be recognized, and used as WAN.
I am trying to configure the router running in access point mode, while using the USB adapter as LAN port.

Groupping usb0 into br-lan like this:

The router won’t be able to get an IP address from DHCP (on another router).

How to configure it correctly?

What is the settings of the WAN interface?

I have factory-reset the router.
After initialization, I have clicked “use WAN port as LAN”.
Nothing more is modified.
And then I have done the groupping of USB0 mentioned in the previos post.


USB0 was in the WAN zone. So can you check the WAN interface configuration in luci?

I have connected LAN on GL-AX1800 to PC, and USB-LAN on GL-AX1800 to router with WAN.

Enabled network from USB:

The interface having USB0 should be TETHERING.

Removing all other ETH, just having USB0 in BR-LAN, it can get IP from DHCP from another router:

However, devices connecting to WIFI from GL-AX1800 cannot obtain any IP address, hence failing to connect to WIFI.

By the way, I have found 2.4Ghz WIFI is not connectable when USB adapter is connected.
I have tried reset the router and played around with WIFI settings.
Simply unplugging the USB adapter 2.4Ghz WIFI works again.

USB 3.0 can create interference on 2.4 GHz according to this whitepaper.


1 Like

Oh yes, I have heard of this before. Totally forgot.

Actually what I am trying to do is, using the USB as 2.5gbps ethernet adapter. Maybe I should wait GL publishing a new model…

You should remove usb0 from tethering in order to let it work as LAN.
tethering interface is part of wan.

I did removed THTHERING, and grouped USB0 into BR-LAN.
Anyway the USB adapter interferes 2.4Ghz WIFI so it is meaningless to fix the setup.

I have bought another GL-MT3000 (CN version).
May I know the difference between the CN version and the international version?


1 Like

I see. It is acceptable to me. The CN version is cheaper.

Since my last reply I decided to use GL-MT3000 instead of AX1800 for my 2.5gbps network.
However, WIFI speed with VLAN configured on MT3000 is horribly slow (around 1mbps).
So I am now trying to configure the USB adapter on AX1800 again.
My plan is to use the USB adapter as LAN interface and provide access to 5ghz WIFI.
I will use AXT1800 for 2.4ghz WIFI.

I have done a factory reset on AX1800.
Afterwards, I have deleted all interfaces and firewall zones.

Interfaces (on AX1800) are then recreated as follow:

LAN, IOT and GUEST are from BR-USB, with USB0.
ETH0LAN, ETH0IOT and ETH0GUEST are from BR-LAN, with ETH0 (WAN port on router).

BR-USB (on AX1800):

BR-LAN (on AX1800):

Wireless configuration (on AX1800):

“5Ghz” WIFI is on USB0, and “5Ghz-Guest” is on ETH0.

Other configuration (on AX1800):

Basically BR-USB and BR-LAN are same in configurations.
Trying to connect to “5Ghz” WIFI from my phone, it won’t be connected.
Even tried to manually assigned an IP, subnet mask, default gateway, it failed.
But connecting to “5Ghz-Guest” just worked well.
There was an IP assigned, and there was Internet access.

I highly suspect there is something hardcoded behind the scene.
So BR-USB does not work like BR-LAN.
“bond0” and “bonding_masters” are suspective.

How should I configure the USB adapter working as a LAN port as if it is a eth*?
i.e. I want usb0 to be eth5


Excuse me @alzhao
Do you think it is due to my configuration, or limitation to AX1800?

I have just found after reboot with USB adapter plugged-in, two interfaces will be created automatically.


It should work. But have to try and find out the reason. Maybe some script is reversing the config.

Maybe Check out mwan3 config. Or disable it completely.

I have tried to empty /etc/config/mwan3 and rebooted the router, but does not work.
It is the same case on both GL-AX1800 and GL-AXT1800.