How to configure mwan3 on GL-AR300m for dual wan connection

Hi,
I just picked up another internet connection at home, I was wondering if I could load-balance the two using gl-ar300m router. Both my connections use PPPoE authentication.
My initial search led me to mwan3 package which does the same, however I’m having hard time on how to configure it, more specifically how to configure LAN port as another WAN. Openwrt guide on mwan3 mentions a switch option under network in openwrt which I’m not seeing here.

Is there any beginner friendly guide or tutorials available on how can I configure it? Any helpful pointers appreciated :slight_smile:
@blue-wavenet plz help

You only need to modify, /etc/config/network files to configure LAN port as WAN port.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd74:c775:cee0::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
        option force_link '1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-AR750-1b4'
	option ipaddr '192.168.8.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option hostname 'GL-AR750-1b4'

config interface 'wan2'
	option ifname 'eth1'
	option proto 'dhcpv6'

hey i configured the /etc/config/network as below:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5a:35a1:9a77::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option force_link '1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-AR300M-5ad'
	option ipaddr '192.168.8.1'

config interface 'wan'
	option ifname 'eth0'
	option hostname 'GL-AR300M-5ad'
	option metric '10'
	option proto 'pppoe'
	option disabled '0'
	option peerdns '1'
	option username '1010649053'
	option password '8447099966'

config interface 'wan2'
	option ifname 'eth1'
	option proto 'pppoe'
	option hostname 'GL-AR300M-5ad'
	option metric '20'
	option peerdns '1'
	option disabled '0'
	option macaddr 'C8:3A:35:0B:2E:01'
	option username 'r7f_407'
	option password '123456'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'
	option disabled '1'

config interface 'guest'
	option ifname 'guest'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.9.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wwan'
	option proto 'dhcp'
	option metric '20'
	option auto '0'

I added the newly created wan2 interface in mwan3 and added it in members and policy as well. It shows both wan online in mwan3 status. However, it still only uses wan for connecting to internet. Also to troubleshoot, I tried disabling then first wan interface, then i’m unable to connect to internet. Although i can do ping openwrt.com via diagnostics. Not sure what I’m doing wrong. Also I added a line in config to override the mac as my old router mac as mac binding is done by ISP.

After adding WAN2, you will also need to configure the relevant firewall rules.
You can configure WAN2 firewall rules in LUCi, refer to WAN’s rules configuration.