How to connect AppleTV, iPhone and others via different subnet


I have brand new 2 routers: GL-AX1800 (default subnet and GL-MT6000 (

This is first router GL-AX1800

  • it is connected with internet
  • it has only LAN connections to: second router (, AppleTV

This is my second router GL-MT6000

  • it is getting internet from first router
  • it has LAN and WiFi connections
  • via LAN I have MacBook that I would pass via AirDrop/AirPlay anything to AppleTV
  • via WiFi I have iPhone that I would do the same, pass anything AirDrop/AirPlay to AppleTV

How can I do that, so all AppleTV, MacBook and iPhone sees each other in 2 subnets?

I do not have any plugins, nothing installed, just pure default configuration with my WiFi named and modified.

Thanks for anything!

PS. I had exactly the same setup with Tenda routers previously and it worked by “default”…

Why do you have 2 different subnets?

No reason, it can be one but when I tried single subnet it went to some issues with errors from router and after a day it disconnected all from WiFi telling „WiFi accessible but no internet”

I would recommend one subnet because Apple highly relies on mDNS (aka Bonjour), and you need to figure out how to get it working across subnets. This is way more complicated than just using one subnet. There are some threads about this here, but you will need to search for it.

Better is to resolve this issue since it seems to be an issue with either a device in your network (like a rogue DHCP for example) or a DNS issue.

Would Access Point help in that case?

Help with what exactly?

@admon share what’s in first router, so second can be AP with DHCP from the first one, so they are all in one subnet?

The way I see it is this:

GL-AX1800 <— Cable 1 —> Apple TV
GL-AX1800<— Cable 2 —> GL-MT6000 (Wifi, other Lans)

If this is your case, then you need to configure your GL-MT6000 as a dump access point. Meaning, DHCP, Firewall etc will be handled from the GL-AX1800 and GL-MT6000 will be completely dump.

In any case, I do have a similar setup and it works just fine as I described.
(In my case I have Flint 2 as my main router and Flint 1 as the dump Access Point)

I am trying this since few hours and for now it is working as expected, perfectly fine, let me see tomorrow, as I have Extender option and later WDS and it disconnected me from the internet after 24h… Disconnected I mean, until I reset router…

This might happen because the repeater function will not try an unlimited number of times to find the Wi-Fi. After the connection drops, it will try to connect again a few times and then stop. This will lead to connection disruption.

In that case, you should check if the Wi-Fi shuts off at night (energy saving mode) or some other odd things happen.

1 Like

How did you do that - “single subnet”?

It is better to solve the problem of why you use two routers other than one.

@alzhao Almost after a day, first router is the main one - no changes, second transformed into Access Point, so all DHCP is coming from first router. For now it is working as expected in a single subnet driven by first router.

I need to have 2 as the first one is close to ISP provider, and we are unable to move it (door entrance), second one is in the living room, spreading WiFi across almost all house. This is the only way I can do it :slight_smile:

1 Like