How to connect to internet with LAN through another router?

I have a GL-AR750S. In the main page, labeled “Internet”, I can connect to my main router with wireless and use GL-Inet router as a repeater. Everything works fine then. The gray circle becomes green, and I can connect to internet through GL-Inet router.

But I’d like to also be able to use LAN as well. So, instead of connecting to my router (the one that has internet) through Wireless, I’d like to just hook them together with an Ethernet cable. I followed these instructions, but nothing happens there. The gray circle remains gray when they’re connected. Although, I can reach the GL-Inet router through my main router with its IP address. However, GL-Inet router cannot access internet from the main router.

A reset of the device didn’t help.

Please advise. Thank you.

You can check the cable is good

But if the cable is broken, how can I access one router through the other?

As I mentioned, when I connect with ethernet cable, I can connect to gl-inet router through my main router without being connected through wireless.

Please provide the return result of the following command

swconfig dev switch0 show 
uci show network

Where do I put these commands? Sorry I’m not that familiar with the OpenWRT yet.

You can ssh to the router, then execute the command.

Here is the output:

root@GL-AR750S:~# swconfig dev switch0 show
Global attributes:
        enable_vlan: 1
        enable_mirror_rx: 0
        enable_mirror_tx: 0
        mirror_monitor_port: 0
        mirror_source_port: 0
        arl_age_time: 300
        arl_table: address resolution table
Port 0: MAC b8:27:eb:a2:fe:3f
Port 0: MAC 2c:4d:54:07:31:1b
Port 0: MAC e4:95:6e:47:7a:c4
Port 0: MAC c8:0e:14:33:68:02
Port 0: MAC 54:60:09:b6:1b:98
Port 0: MAC 00:1e:06:35:ef:5f
Port 1: MAC c8:0e:14:33:68:02
Port 1: MAC 54:60:09:b6:1b:98
Port 1: MAC 00:1e:06:35:ef:5f
Port 1: MAC b8:27:eb:a2:fe:3f
Port 1: MAC b8:27:eb:70:14:c1
Port 1: MAC 2c:4d:54:07:31:1b

        igmp_snooping: 0
        igmp_v3: 0
Port 0:
        mib: MIB counters
RxBroad     : 618563
RxPause     : 0
RxMulti     : 115456
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 125429
Rx128Byte   : 961432
Rx256Byte   : 144424
Rx512Byte   : 47947
Rx1024Byte  : 17116
Rx1518Byte  : 19214
RxMaxByte   : 1875
RxTooLong   : 0
RxGoodByte  : 166454821 (158.7 MiB)
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 948991
TxBroad     : 607563
TxPause     : 0
TxMulti     : 108321
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 994499
Tx256Byte   : 54999
Tx512Byte   : 26660
Tx1024Byte  : 108401
Tx1518Byte  : 91
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 155703672 (148.4 MiB)
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

        enable_eee: ???
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 0
        link: port:0 link:up speed:1000baseT full-duplex txflow rxflow
Port 1:
        mib: MIB counters
RxBroad     : 604266
RxPause     : 0
RxMulti     : 107220
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 806935
Rx128Byte   : 182869
Rx256Byte   : 54003
Rx512Byte   : 26507
Rx1024Byte  : 108251
Rx1518Byte  : 82
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 150360477 (143.3 MiB)
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 38
TxBroad     : 5165
TxPause     : 0
TxMulti     : 99
TxUnderRun  : 0
Tx64Byte    : 119975
Tx128Byte   : 93157
Tx256Byte   : 91925
Tx512Byte   : 19378
Tx1024Byte  : 16582
Tx1518Byte  : 20473
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 82557361 (78.7 MiB)
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 2
        link: port:1 link:up speed:1000baseT full-duplex txflow rxflow auto
Port 2:
        mib: No MIB data
        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 1
        link: port:2 link:down
Port 3:
        mib: MIB counters
RxBroad     : 3297
RxPause     : 0
RxMulti     : 1101
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 3757
Rx128Byte   : 1415
Rx256Byte   : 578
Rx512Byte   : 140
Rx1024Byte  : 147
Rx1518Byte  : 8
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 607895 (593.6 KiB)
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 2
TxPause     : 0
TxMulti     : 38
TxUnderRun  : 0
Tx64Byte    : 3893
Tx128Byte   : 801
Tx256Byte   : 977
Tx512Byte   : 486
Tx1024Byte  : 255
Tx1518Byte  : 552
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 1693803 (1.6 MiB)
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 1
        link: port:3 link:down
Port 4:
        mib: No MIB data
        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 0
        link: port:4 link:down
Port 5:
        mib: No MIB data
        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 0
        link: port:5 link:down
Port 6:
        mib: No MIB data
        enable_eee: ???
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 0
        link: port:6 link:down
VLAN 1:
        vid: 1
        ports: 0t 2 3
VLAN 2:
        vid: 2
        ports: 0t 1
root@GL-AR750S:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd46:6495:37f8::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.hostname='GL-AR750S-ac4'
network.lan.ipaddr='192.168.1.15'
network.lan.ifname='eth0.1 eth0.2'
network.lan.gateway='192.168.1.1'
network.wan=interface
network.wan.proto='dhcp'
network.wan.hostname='GL-AR750S-ac4'
network.wan6=interface
network.wan6.proto='dhcpv6'
network.wan6.auto='0'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='2 3 0t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='1 0t'
network.wwan=interface
network.wwan.proto='dhcp'
network.wwan.metric='20'
network.guest=interface
network.guest.ifname='guest'
network.guest.type='bridge'
network.guest.proto='static'
network.guest.ipaddr='192.168.9.1'
network.guest.netmask='255.255.255.0'
network.guest.ip6assign='60'
network.ovpn=interface
network.ovpn.ifname='tun0'
network.ovpn.proto='none'

Your eth0.1 is bridged with eth0.2 and you set the static IP address 192.168.1.15. Where did you set it?
What is the purpose of this?

I don’t know about the bridge, but I set the IP of the gl inet device to 192.168.1.15 (which is done in the main settings of gl inet, without involving OpenWRT/luci, which can be found, after inputting the password, in MORE SETTINGS then LAN IP) because I want to be able to access it from the first router, so I put it in the same subnet, and I set the gateway to 192.168.1.1 because that’s the IP address of the main router.

In this case, your router no longer has a WAN port, it is now equivalent to a normal switch

This should be AR750S below the client can not access the Internet, what is the IP assigned to your client?

OK, I think I know how the bridging happened now. On the main page of gl-inet, there’s an option to use the WAN port as LAN. I chose this option because it was recommended by the tutorial, whose link I put up there.

I gather from what you said that I should switch that option back to WAN, and connect my gl-inet to the main router through the WAN port. Is this the right way to do it?

I really never used WAN before and I don’t know what it’s good for.

About the IP address assigned to the client, I’ll get this information for you within around 12 hours. I can’t access the router through its wifi right now.

Unfortunately, I was unable to get the IP information. I’m not at home and can’t retrieve it until a week from now.

Btw, I wanna point out that I block IPv6 from the OS. I don’t know if that has any effect. I do this because I want to guarantee that all connections go through VPN. Otherwise, connections that don’t go through VPN go through.

Can you please answer the question in my last comment?

Disabling IPV6 won’t make a difference. You can also set devices under AR750s to static IP, such as 192.168.1.16