How to Disable DHCP only for LAN (Ethernet) devices, not for Wifi Devices?

I use my SFT 1200 as a bridge between:

  • local Network 10.180.210x (wired ethernet)
  • Wifi 192.168.178.x (wifi client over sta)
  • Wifi server (so i can access with my laptop for example)

Its working pretty good, but i recently had the problem that my lan devices get their IP Adresses from the router instead of the DHCP server.

Is it possible to disable the DHCP Server only for ethernet devices? i saw that there is a “ignore DHCP” in the LAN interface - but this is for Wifi and Ethernet devices.

Thank you!

I would say that this is not possible using default ways since both interfaces are 1 big network connected via the br-lan bridge.

To make it possible you should split it up in different networks.

Hmm can you show me how your bridge has been configurated? (I guess this is from the gl UI?)

I think this is surely possible, maybe not in the gl ui but in luci, but i need to get a better picture.

So if i understand correctly you want:

  • Lan ports to be part of wan network so the ports share the networks of the upstream lan?

  • you want wifi to be having the network from your wireless ?

Im afraid this will not work in the gl ui, theres probably two ways how i would approach it:

Either the simplest way:

a mix between a dumbap and a routed ap (see the swap for network interface for the wifi) but instead of giving them a fixed ip i set them up as dhcp clients as protocol, please check the tutorials, the dumb ap one has really good videos :wink:

The advanced way (not recommended for new users):

push vlans if possible, and then use routed ap as dhcp clients with these vlans.

^ Note if you do this for any of the two, gl ui will only work with limited functionality things like the clients tab, or some other features may ghost (i currently run a flint 2 like this in dumbap), but well i don’t need these features.

I’m wondering if kicking the Wi-Fi duties over to the Guest VLAN, then disabling DHCP on Main/Private LAN wouldn’t do it. Tacking option dhcpv4 'disable' to /etc/config/dhcp’s lan entry might just be enough.

@FSchipmann : Make a backup before you start getting all experimental:

1 Like

Hmm im not sure if that works but maybe it does :slight_smile: , i think the protocol should be dhcp client or unmanaged, but i dont know how unmanaged takes it so maybe its the same result as disabling dhcp.

Well, I’m guessing based on the option dhcpv6 'disabled' for my guest block. I’m too lazy ATM to bother looking it up on the OpenWrt Wiki.

1 Like