How to fix DNS leak on MT300N-V2?

Hi all,

I’m using the Mango router with a Surfshark OpenVPN and concerned about the DNS leak I am seeing.

I don’t see any DNS leaks when using Surfshark’s native app on my desktop/mobile.

Wondering what settings I can adjust on the Mango to resolve this?

DNS leak was tested from:

Current setup

  • Mango router is current acting as a repeater for the local router where I am staying.

  • Router: GL-MT300N-V2 Mango

  • Firmware: v4.3.11

  • DNS Settings

  • Do you use DHCP or static IP addresses?

    • I think DHCP, default settings as well

Pretty new to setting all this up, so any settings you can suggest would be appreciated!

If you use vpn, there should be vpn dns displayed.

Can you show screenshots when vpn is connected?

I don’t see the DNS over OpenVPN option.

Here’s what I see with Wireguard or OpenVPN turned on in DNS:

I tried this setting based on another post)

This seems to have resolved the issue of the leaked DNS, which now just say Cloudflare but points to the correct country on my VPN instead.

Not sure if this the optimal solution though.

1 Like

Anyway I will make this as resolved.