How to force VPN to DISABLE upon (re)boot?

All my 750S’ usage is in hotels with captive portals, and after I’ve validated to the hotel I’ll turn on my Wireguard VPN (to avoid streaming service traffic shaping (if any)). But then I check out, check in somewhere else (sometimes weeks later) and futz around for a few minutes trying to figure out what’s wrong when trying to authenticate to the current hotel’s portal, only to realize the VPN came back on after a reboot (and as Wireguard is UDP, there’s no “feedback” like OpenVPN that you’ve actually connected).

Devs, please add a switch in the VPN setup (or policies) that will change the behavior of the VPN to “always once connected” or “only until (re)boot”. (I’m running the “Fix Policy” firmware snapshot on my Slate, if it matters). In the meantime, is there a file or script I can add to the current firmware to do this?


then you will also need a “disconnect, but no restart on reboot” and “disconnect,but restart on reboot” to go with that for openvpn, wireguard, and shadow socks each


since you using wireguard you can assign wireguard to slide button and always know if vpn enabled or disabled by looking at the router.

you can use /etc/rc.local to stop your vpn services on reboot. that file gets executed once on reboot.

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

/etc/initd.d/<your_service> stop

exit 0


Why would each service require a setting, and not this globally? If, on reboot, before bringing up whichever VPN/Socks service, see if the “Please don’t do that on reboot” flag is set, and if so bail.

sorry I interperted wrong. my incorrect sloppy reading interprededted as a replacement for the “connect” button for the vpn, then taking to the next step and thinking of all three client vpns then thinking about well what about if he wants to disconnect temp but decides to change his setting… I went puff puff (no pass) puff puff puff. :wink: