How to get Tailscale working on the Beryl MT-1300!

I wanted to use a Tailscale mesh rather than a self-hosted hub and spoke wireguard vpn for my site to site.
This is how I got it working on the Beryl (after some trial and error), it may work on some other devices.

  1. Go to and download the firmware version you currently have installed - if you need to restore, you might not have internet.
  2. Download/Backup your config. I can’t remember if you can do it through your GUI in 3.x, otherwise you can do it in the advanced Luci GUI in systemBackup/Flash Firmware
  3. Go back to and download the latest 4.x firmware - we need the new Tailscale GUI on the OpenWRT 22 to support tailscale
  4. Flash it using the GUI installer.
  5. When my router came back up it wouldn’t get a DHCP address from my Modem even after a restart of both - I had to switch ports in the modem and maybe restart the modem.
  6. ApplicationsPlugins → search tailscale
  7. Install gl-sdk4-tailscale
    I. It should auto-install the other 3 search results
  8. Reboot router
  9. ApplicationsTailscaleEnable Tailscale

  10. I. Im not sure how allow remote access WAN is helpful - presumably it is a stand in whilst they get --advertise-exit-node working - I would disable it for now.
  11. You will get a link to ‘bind device’, this didn’t work for me
  12. Instead SSH into the router then run tailscale status, the binding link should appear, copy and paste it and authenticate
  13. You should see in the Tailscale admin panel that the device is now connected. You can allow any advertised routes here.

Now at this stage, whilst SSHed into the router I could ping devices on the Tailscale network and on exposed subnets, but devices on my home network, couldn’t. I.e beryl wasn’t routing the packets, pings from devices returned “Destination unreachable”. Which rather undermined the idea of site-to site. But looks as if this may not be unique to the Beryl: Tailscale cannot reach subnets on other devices - #7 by jsr

To fix:

  1. Log in to the advanced Luci GUI panel, go to NetworkFirewall (not StatusFirewall)
  2. Edit the first row
  3. On the second tab add covered devices: tailscale0
  4. Save and Save & Apply

Edit: I find that every few days the routing fix breaks (I think something refreshes the routing tables or similar) disabling and then re-enabling the tailscale fixes it.


Solution is above - marking as solved
@alzhao - are you interested in rolling this out?

We may not fit Tailscale for MT1300 but for the “reach subnets” thing should be fixed (or have already been fixed).

That is sad, because it is working well, it would be a shame for you not to add a feature to a product that supports is :frowning:

Fixed in which version? I still lose routing to exposed subnets on other parts of my tailnet every 36 hours or so (I can still ping all nodes on the tailnet). Simply disabling and enabling fixes it though

After more testing tailscale struggles to do more than 20Mbs / 2-3MB/s throughput :frowning:

I upgraded manually to a more recent version of tailscale (1.44) using the packages from here: Index of /releases/23.05.0-rc1/packages/mipsel_24kc/packages/

However I didn’t get an appreciable increase in speed.

1 Like

Hmm, I tried this but:

  • I had to install the UI package as well
  • I don’t have “wgclient”
  • (via SSH) I can connect to devices on remote networks (advertised as routes on other tailscale nodes) from the MT-1300 and I can ping other tailscale IPs from the MT-1300
  • I can’t connect to remote devices or ping tailscale IPs from any LAN devices (eth or wifi)
  • I tried adding routes for the subnets manually and pointing them at tailscale0 interface but that didn’t work.

Any ideas? I’m running the latest beta firmware (4.3.7 release 1, also tried upgrading to the 8/23 4.3.7 snapshot)

Edit: I followed the instructions here for the luci changes and it works: Tailscale cannot reach subnets on other devices - #23 by ss4pcRFradio

1 Like

Would zerotier perform any better on Beryl?

See the points after point 12 for how I solved routing from LAN to tailnet


did you get custom exit node to work? In my case it just won’t work and either do nothing and I connect to internet normally without any routed traffic or after switch off/on Internet connection just stops working. I checked the exit node with my phone at it is working properly there.