How to load "clean" OpenWRT onto AR-300M

I have been testing an AR-300 and so far so good. However, I need to also test it running OpenWRT only. I had thought this was easy/possible, but it hasn’t worked as I’d expected.
I was running the current version (v3.203). I factory defaulted (revert firmware option), then looked for firmware options. Looking in https://fw.gl-inet.com/firmware/ar300m/, I found openwrt-gl-ar300m-clean-2.264.tar and uploaded this via the Upgrade/Local Upgrade menu. The verification passed, but warned it was older than the current or 3rd party firmware. I selected to NOT keep settings, then installed it. After a long time, I was unable to reach the unit and I noticed it was not supplying DHCP. Only the green light and no others are showing.
I have tried to power cycle (about 30 mins later), but still only the green light and no DHCP. I am guessing I’m going to need to try uboot to get something working again.
What I’d like to know is what is the recommended method to use “clean” OpenWRT?

For clean openwrt, pls just download firmware from openwrt website.

Old firmware may have compability problems.

Thanks. I will look.
Since then I have also rebooted by AR-300M 3 times and found it boots with the NOR firmware now. I’m still learning what this really means. Assuming I can find the right OpenWRT build to load, I’m assuming I should get my original GL.inet firmware back onto the NAND first. How do I go about restoring this?
Just to make my question more specific:
Following this page GL-AR300M Series - GL.iNet Docs Do I need to follow the debrick process, then from uboot load the NAND firmware (https://dl.gl-inet.com/firmware/ar300m/nand/v1/ and then use openwrt-ar300m-3.203-0701.img)?

Pls check this guide GL-AR300M (Shadow) - GL.iNet Docs

I followed the debrick process, got to the uboot and uploaded the NAND firmware. It has now returned to the same FW it had before - all working thanks.
Now I will return to my original mission to re-flash it with OpenWRT only firmware.

Thanks alazhao for your help. I will list what I did here in case anyone else needs it.
Follow the debrik process in the doc to get to uboot. Check the OpenWRT page for this device (it’s not really up to date, but it does link to the current build for this model (at the time of this post 21.02.1). In this page there are a lot of options. I used the file called glinet_gl-ar300m-nand-squashfs-factory.img. Browse to this file and click the “update gl-inet firmware” button. The 3rd LED (wlan light) will flash red a bit, then it will reboot. The 1st LED will flash green, then flash faster (I think for about 30 secs), then it will (I think) reboot and both LEDs will show green.
Change the NIC on your computer back to DHCP and you should get an IP and be able to browse to 192.168.1.1 and reach the OpenWRT interface.

1 Like