How to restrict WAN access for VPN Client (Mango)

I have the following setup at home:

  • Brume2 as the main router ( which distributes IP address (DHCP);
  • After Brume2 I have unmanageable switch with all home devices connected to it;
  • Mango router (WAN is also connected to this switch and I use it to run the WireGuard VPN Server (corresponding port forwarding rule is set in Brume2).

VPN Server works fine, however, my intension is to use Mango router ONLY as a VPN Server and RESTRICT access to my home network devices for the connected VPN Clients (via WAN).

When the “Allow Access Local Network” option is disabled, there’s no access to the devises connected to the Mango network (LAN), but it doesn’t affect Mango’s WAN subnet.

Is there any way to setup the firewall rule in order to restrict the access to the upper level devices? Probably to everything except the main Brume2 (

I appreciate any help in this matter.


I’m currently actively studying the Wireguard documentation, but I can’t say that I’m good at it :slight_smile:
But, if you use a mobile device as a WG client, in my case it is an iPhone, in the WG APP client settings when editing allowed IPs, it is possible to activate the button “exclude private IPs”.
Then you can simply add to the list of allowed ip wich you need to access your local network. For example, your Brume2, as address and you will have an access to your Brume from your mobile phone, while other IP addresses on the same subnet will not be available. For me it works. But I find it useless as an elevated user can always edit the profile and override excluded private addresses and access them.

Hi Agent_smith, thanks for the advice. But as you said, this setting is on the Client side, not the Server, so indeed anyone can change. :frowning:
I’m trying to play with the firewall rules in Luci, but no success so far.

I don’t quite understand your question.
What other devices do you have in your home network? It would be nice if you could draw a network topology diagram.

Yes. But if you use wireguard server on your Brume2 directly, this could be resolved, right?

Hi Alzhao,
For the personal use I run another VPN server on Brume2 with the full access to the LAN.
The purpose of Mango router is to provide the VPN access to friends, colleagues, etc. who are abroad and need to be ‘in the home country’, but I wanted to forbid the access to my home LAN for them.

The solution was to change the ‘WireGuard’ Zone Firewall settings and to add the ‘WireGuard to WAN’ restriction in the Traffic Rules.
Now the VPN Clients can only access the Mango router via (wg) and (wan) IPs, but the route to the main LAN (via WAN port) is restricted.


In your case, I would add some details, would close access to VPN clients to the internal network for ZONE wareguard> WAN Input > Drop, so they can’t reach the web interface of the mango router at IP and I would create another traffic rules that allow only IP address of your personal VPN client for Mango(e.g. with an IP, see my e.g below), to access to the mango shell, brume shell and other ip addresses from internal network, if required. Very important ! It must be dragged and droped above the deny rule in your case “forbid-wg-to-lan” then saved and applied.

Hi agent_smith, thanks for your input!
Actually my intension was to allow the VPN Clients to access the Mango, as I have an external drive connected to the router and can share the files with my colleagues in that way. '\\\GL-Samba'
Since the Mango’s WEB interface is password protected I’m not worried that anyone can actually login into it.