How to set address

I have a GL.iNet GL-AR300M16-Ext Mini and in router mode the IP ranges it assigned default to - xxx, I have a cable connected to the WAN port.

My main Asus wifi router uses the - range for LAN and wifi devices.

The problem I am having is that the devices connected to the Asus cannot see/talk to the devices connected to the AR300M (i.e. my wired PC) but the other way around seems to work, from the 192.168.8.x devices talking to the 192.168.0.x devices.

One easy way would be to set the AR300M to AP mode (I have two Asus router in AP mode like this) but it still assigns 192.168.8.x IPs and if I try to change that to address it says conflict.

The repeater mode doesn’t work as the signal from the Asus is too weak.

How can I have two Asus wifi routers in AP mode and they work just fine with the 192.168.0.x range but the AR300M does not?

In Router Network Mode, the GL-AR300M16 firewall blocks WAN-to-LAN traffic, but allows LAN-to-WAN traffic.

The GL-AR300M16 should work in Access Point Network Mode for your use case. Is IP address already used by your Asus main router or other existing network device? You can let DHCP assign an unused IP address to the GL-AR300M16.

I do not work for and I am not directly associated with GL.iNet

Yes that is what I have tried, the IP assignment is DHCP and the AR300M picks up the address but any devices connected to the AP still get a IP and I did assume it would get

The client devices should be getting IP addresses from the DHCP on the Asus router and the DHCP on the GL-AR300M16 should be disabled. Maybe they still “remembered” the previous IP address.

Can you run “ipconfig/all” in a Windows PC command prompt, which should show the Default Gateway, DHCP Server and DNS Server to be the IP address of the Asus router? If not, then run “ipconfig/renew”.

You should not change IP to the same as your upstream router. It is just not correct.

You should set up a bridge mode on AR300M (AP, WDS or Extender) in more settings->network mode.

If you are still seeing “More Settings” - “LAN IP” then you’re most likely still in router mode and not Access Point mode. The options you get in AP mode are much less.

Yes I will try connecting a new device when in AP mode and see if it does give the correct IP.

Yes I had selected AP mode, I will try to do that and reboot the device then connect.

Ok I have tried the AP mode and power cycling the router and now I can see the correct IP range, thanks guys.