How to set static IP addresses for interface, Gateway and DNS-Server

I need to configure a AX1300 as a host within an existing LAN for providing a SAMBA service.

All tasks except the latest point are working fine:

  1. disabling WLAN’s and guest WLAN’s
  2. enabling SAMBA (inserting an USB drive, adding an user, etc.)
  3. setting a static IP address for the LAN interface(s), disabling DHCP service, setting a manual IP address for the existing router (and DNS server) in the LAN

How to realize the full configuration for step 3?
I could set the IP address but the device can’t connect to the internet because there’s no option to set the default gateway. A DNS server may not be needed for the device but of course it would be fine to control this setting as well.

You can should be able to do Step 3 via the setting pages under LuCI → Network → Interfaces → LAN.

I do not work for and I am not directly associated with GL.iNet

Thanks for the tip, didn’t see this menu point before…

Tried that, DHCP could be disabled and also a Gateway has been added (I’ve applied also all pending changes) - so the configuration looks fine. Anyhow the standard admin panel still says “No Internet Connection! Find a network to reconnect” (for instance on the upgrade page).

Add Step 4: Disable and stop gl_monitor via LuCI → System → Startup . You may also have to disable and stop mwan3.

I use my GL-MV1000W in a similar setup, as a LAN-only AdGuardHome server. Your router may be somewhat different if it is running Firmware 4. I disabled a few more services that are not used in this configuration.

Did not find gl_monitor in the list, only carrier-monitor.

Now I also added a default route (System/Static Routes) which works (checked by using Network/Diagnostics/TraceRoute) but only with IP addresses, not with DNS names.

Without the static route, all pings get lost.

So the interface configuration seems to be ignored (I have set the default gateway in ‘General Settings’, checked ‘Use deafult gateway’ and configured ‘Use custom DNS server’ in ‘Advanced Settings’).

It looks like the router has Firmware 4 and I do not know what produces the “No Internet Connection! Find a network to reconnect” message in that version. carrier-monitor is different, so you should not disable it. Have you tried disabling and stopping mwan3?

I am not certain what you mean by the above, but LAN IPv4 address has to be a new IP on the same subnet as your main Internet router, LAN IPv4 gateway has to be the IP address of your main Internet router and LAN Use custom DNS servers can just be temporarily for testing.

1 Like

Didn’t see any changes when killing mwan3 as proposed, but DNS is doing it’s job right now (anyhow I have no idea which of my changes in differerent checkboxes is responsible for that behaviour)…
…thanks for your help again.

But - the interface configuration for the default gateway (including the checkbox ‘Use default gateway’) is still ignored and the error message is still present…

…but the box is working now and maybe a new firmware will do a better job somewhen.