Huawei E3372 LTE USBstick and 300M

Hi all,
I have a 300M, and I am trying to use a E3372 LTE USB stick. I was able to connect once, but now I can\t connect to the internet. It is not the Tethering stick.

If I use modemmanager and follow this guide: Techship - FAQ - How-to guide: control and set up a data connection in Linux using ModemManager as connection manager?

I am able to get it to work, strangely enough it changes this output:

mmcli --list-modems
/org/freedesktop/ModemManager1/Modem/3 [huawei] E3372
The 3 was 1 use 20 min. ago?

Status of modem:

root@GL-AR300M:~# mmcli --modem=3

General | dbus path: /org/freedesktop/ModemManager1/Modem/3
| device id: 60cf8eb711c390e85bcf1814b1a58fe1c09b989e

Hardware | manufacturer: huawei
| model: E3372
| firmware revision: 21.328.62.00.104
| supported: gsm-umts
| current: gsm-umts
| equipment id: 868230030069417

System | device: /sys/devices/platform/ahb/1b000000.usb/usb1/1-1
| drivers: option, huawei_cdc_ncm
| plugin: Huawei
| primary port: ttyUSB0
| ports: ttyUSB0 (at), ttyUSB1 (at), wwan0 (net)

Status | unlock retries: sim-pin (3), sim-pin2 (3), sim-puk (10), sim-puk2 (10)
| state: disabled
| power state: on
| signal quality: 0% (cached)

Modes | supported: allowed: 2g; preferred: none
| allowed: 3g; preferred: none
| allowed: 4g; preferred: none
| allowed: 2g, 3g, 4g; preferred: none
| current: allowed: any; preferred: none

IP | supported: ipv4, ipv6, ipv4v6

3GPP | imei: 868230030069417

3GPP EPS | ue mode of operation: csps-2

SIM | dbus path: /org/freedesktop/ModemManager1/SIM/3

And if I run this:

mmcli --modem=3 --enable
mmcli -m 3 --simple-connect=‘,ip-type=ipv4’
I get internet.

But I want the GLiNet to handle the internet.

Does the UI detect modem as ttyUSB?

1 Like

Not sure how, but now it works.

Thanks for replying.