Huawei E3372h-320 on GL-MT1300 connection problem

Getting a Huawei LTE working on a GL-Inet router seems to be a hard problem considering the numerous postings. I could not find one that solved my issue.

I would like to be able to simply insert the modem and connect via the webinterface of the router. I did not try to get the modem connecting on one of my computers.

I have a GL-Inet GL-MT1300 with:
firmware: Current Version 3.211
kmod-usb-net-cdc-ether 4.14.241-1
usb-modeswitch 2017-12-19-f40f84c2-2

And a 4G USB modem: Huawei E3372h-320

I edited /etc/usb-mode.json and inserted (a new version of usb-modeswitch probably has this device listed already) :

            "12d1:14db": {
                    "*": {
                            "t_vendor": 4817,
                            "t_product": [ 5321 ],
                            "mode": "HuaweiNew",
                            "msg": [  ]


T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 5 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=02(comm.) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=12d1 ProdID=14db Rev= 1.02
S: Manufacturer=HUAWEI_MOBILE
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr= 2mA
A: FirstIf#= 0 IfCount= 2 Cls=02(comm.) Sub=06 Prot=00
I:* If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=06 Prot=00 Driver=(none)
E: Ad=83(I) Atr=03(Int.) MxPS= 16 Ivl=2ms
I:* If#= 1 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
I: If#= 1 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

When the Huawei modem is inserted, dmesg shows:

[ 347.572851] usb 1-1: new high-speed USB device number 5 using xhci-mtk
[ 347.834655] cdc_ether 1-1:1.0 eth1: register ‘cdc_ether’ at usb-1e1c0000.xhci-1, CDC Ethernet Device, 00:1e:10:1f:00:00
[ 347.851116] cdc_ether 1-1:1.0 eth1: unregister ‘cdc_ether’ usb-1e1c0000.xhci-1, CDC Ethernet Device

To me the unregister seems wrong. Is that correct, and how can it be fixed?
And how can I connect to the Internet using the modem?

Thank you for any help.

I just think you need to change the LAN IP of the router from, as I think most Huawei modems use this also.

1 Like

It should work in tethering and you should just leave it work in tethering.

Just change LAN IP to avoid IP conflict.

What happens when you click on the Admin Panel → Internet → Tethering?

EDIT: The “h” in “E3372h” is supposed to stand for “HiLink”, which works like Ethernet adapter.

I do not work for and I do not have formal association with GL.iNet

Thank you. The panel looks like your image, and nothing happens.

I changed the network to to allow for Huawei on

Reading about the Huawei modem I found out that there are many versions of Huawei E3372, and they are really different.

Last night I made a serious step forward. I booted my PC from a Debian live image (version 11.3 with non-free binaries), inserted the modem, selected it using the networkmanager, and opened a browser. The Huawei modem routed me to that has a control page for the modem. After configuration I had an Internet connection via de Huawei modem.

When configuring the Huawei modem I learned that the Huawei mother-ship wants to know everything from you. I think this will be my last Huawei product.

I gave the Huawei modem another try with my GL-MT1300: the modem immediately unregisters.

Would kernel 4.14 (from 2017) be too old to handle the modem? Or is the modeswitch wrong?

I have no idea why it unregisterred immediatelly. Very strange.

Can you make sure the power adapter is good?

I switched the power-adapter for a known good one: same result,
unregister after 20ms

Interesting point: the LED turns blue, indicating a 4G connection

There are some online posts from people who have flashed the firmware to switch from HiLink to modem. You can Google for them if you want to try. :grin:

I do not work for and I do not have formal association with GL.iNet

Not really my cup of tea, but thank you pointing it out

I’d try resetting the dongle (think they call it “system reset”) via the GUI and try again.
At the same time might be worth doing a factory reset of the router.

I have a 3372h (not exactly the same model as yours) and it works in tethering mode, no problem.

I did a full reset of the modem and GL-MT1300, set the LAN-IP, and now it works! Some bit must have tumbled. All that is left is configuring Wifi and VPN.

Thank you all very much. I am so happy to have a truly wireless router with Wifi.