I can remote access through myddns.glddns.com with port 80 (http) but not port 443 (https)

Model No.: GL-MT300N-V2
Software version: 3.102
I have enable both the http and https access in the ddns part.
I have also set the port forward on the previous router for both port 80 and 443,
but I encounter a " ERR_CONNECTION_TIMED_OUT" by using chrome when access to https://myddns.glddns.com, but have no problem when access to http://myddns.glddns.com

I hope I can only enable https access for a better security.

can you try a different port on your main router’s port forward settings?

e.g. 444 forward to 443, then use

Just check if your operator blocks this port

1 Like

The 443 is used by other service and it become ok now after changing the port forward setting for “443 to 443” to “1443 to 443”

1 Like