Im having a problem running cyberghost


#1

having a problem running cyberghost keep getting a message like this one first

Expected Remote Options String (VER=V4): ‘V4,dev-type tun,link-mtu 1574,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,cipher AES-256-CBC,auth SHA256,keysize 256,key-method 2,tls-server’
TCP/UDP: Preserving recently used remote address: [AF_INET]31.171.152.137:443
Socket Buffers: R=[163840->163840] S=[163840->163840]
UDP link local: (not bound)
UDP link remote: [AF_INET]31.171.152.137:443

then this next

TCP/UDP: Closing socket
SIGHUP[soft,tls-error] received, process restarting
OpenVPN 2.4.5 mips-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD]
library versions: OpenSSL 1.0.2o 27 Mar 2018, LZO 2.10
Restart pause, 5 second(s)

i have tried different servers and standard and premium but nothing working i got the gl-ar750s slate also my firmware is 3.009


#2

Can it work on your PC? You can download OpenVPN client on your PC, and upload the configuration files, to check if it can work.


#3

it’s works on windows 10 and linux mint but seem to not work on the gl-ar750s


#4

Never try cyber ghost myself. Can you post the ovpn file? Mark your credentials before you post.


#5

when working with openvpn I found when I get a
reserving recently used remote address: [AF_INET]31.171.152.137:443
response I always do a hard reboot and test again.

post your .conf file. do not include user auth info


#6

I don’t have much experience working with cyberghost, but my friend runs it on windows 10, didnt have a problem with setting up. Can you post your config? I’ll ask him for advice.


#7

I have the same problem with cyberghost and gl-ar750s slate.

In my case, cyberghost works on Android and on a GL-AR150 router but not with slate.
the ovpn file is:

client
remote *********.net 443
dev tun
proto tcp
auth-user-pass
resolv-retry infinite
redirect-gateway def1
persist-key
persist-tun
nobind
cipher AES-256-CBC
auth SHA256
ping 15
ping-exit 90
ping-timer-rem
script-security 2
remote-cert-tls server
route-delay 5
verb 4
comp-lzo

ca ca.crt
cert client.crt
key client.key


#8

client
remote 4-1-gb.cg-dialup.net 443
dev tun
proto udp
auth-user-pass
resolv-retry infinite
redirect-gateway def1
persist-key
persist-tun
nobind
cipher AES-256-CBC
auth SHA256
ping 5
ping-exit 60
ping-timer-rem
explicit-exit-notify 2
script-security 2
remote-cert-tls server
route-delay 5
tun-mtu 1500
fragment 1300
mssfix 1300
verb 4
comp-lzo

ca ca.crt
cert client.crt
key client.key


#9

I have tested firmware versions from 3.002 to 3.009 and nothing changes.

Any idea?

Thanks in advance


#10

You are authenticating with a certificate - so you do not want auth-user-pass.


#11

did you try without auth-user-pass?


#12

Do you mean the line “key client.key” is identifying him so he doesn’t need auth-pass?


#13

Yes. Also, auth-user-pass requires a parameter of a file name containing the username and password which seems to be missing in both above configurations.

I’m wondering if they uploaded that config through the GL web UI and it inserted the option and when it asked for the username and password the user left the option blank and the resulting configuration file is broken


#14

Yes, I just checked -once uploaded the line should look something like this:

auth-user-pass /etc/openvpn/ovpn/auth/usrpwd.txt


#15

Now I am using bmxscott config file and it is working. Seems to me that Cyberghost has changed something since I tried this configuration before and it failed.

nopro404, you are right: I have to insert manually the username and password through the GL web UI when upload the config file.

Thanks everybody for your help.