Incomplete directory returned from DLNA server

I want to use my Gl-inet Router as a DLNA server for a hard disc connected via USB.
I have followed the guideline

and the DLNA server is listed in client devices - but the returned directory of files and folders is incomplete - there are simply files and folders not listed that exist on the hard disk.
Any idea what may be the root cause ?
Thank you !

Which router are you using?

I have tried it out with 2 routers:
GL-AR750 and GL-MT1300
Both updated on the newest Firmware.

The Hard Disk is a Seagate Portable Drive, working with other routers, e.g. Fritzbox 7430

You’d better use firmware 4.x for these models because the DLNA function is optimized.

I know this behaviour from minidnla at Linux desktops as well as Qnap DNLA implementation.
How many objects are in your source?

My experience:
470 folders (movies and series) are slow, but no problem.
3700 files (music) are cut in view.
20000 files in 700 folders (photos) could lead to reach while indexing.

1 Like

Hello alzhao,

thank you, I have upgraded my GL-AR750 to firmware 4.3.2 - but now there is no more option under “Applications” to enable file share via DLNA. No dlna server is visible anymore on my client devices.
Could you please help me to enable the dlna server and proceed the test?
Thank you !

4824 files, 148 folders
Let’s await what the upgrade to firmware 4.3. will bring …

I have found here

that there should be a menu item:

Admin Panel → APPLICATIONS → Network Storage
to enable DLNA, but for my GL-AR750 this menu item does not exist, there is only “Plug-Ins”, “Dynamic DNS” and “GoodCloud” under “APPLICATIONS”

I see. These packages are too big to be included in the firmware for these routers.

Can you use exroot and install these packages?

Hello, I have also tried with my GL-MT1300, but unfortunately same issue (no Network Storage Menu Item).
Which GL router model has sufficient internal storage ?
The recommended packages are not available in the list of installable Plug-ins.
Or can you please explain what “exroot” is and how to use ? Never heard of it!
thank you !

Try installing the following packages

gl-sdk4-nas-utils gl-sdk4-nas-web minidlna gl-sdk4-ui-nasview

None of the recommended packages
“gl-sdk4-nas-utils gl-sdk4-nas-web minidlna gl-sdk4-ui-nasview” are available in the Plug-ins list. Could you please advice where to get these from and how to install them?
thank you !

How many pacakges do you have in the plug in page?

Maybe it is snapshot firmware and the repo is not finished.

I have ordered a new GL-AXT1800 - this has arrived today and I upgraded it to 4.2.1.
The network storage option is available in 4.2.1 and I have enabled DLNA.

Unfortunately the original problem has not change - the returned content is incomplete, there are 4 folders on top level, one folder is never displayed, another folder is displayed but shows no content or progress indicator when browsing.
I don’t know what to do.

Can you contact us via email? I want to ask some details like the file system and folder names etc.

Are there nonstandard characters in one of the path/filenames?

I remember of a embedded DLNA Box, that where not able to interpret unicode characters in filename, from YouTube Videos, ripped with youtube-dl.
Not the unicode file was skipped, all files behind in the DLNA index, as well.

Thank you, I have reviewed and restructured the files and folders on the hard disk. I have not found files with non standard characters.
And after a reboot, my AXT-1800 started to show all the folder and files. So currently, for this unit the problem seems solved.
Regarding my older units (MT1300) I am still seeking for the right firmware version to maybe get it running too.
I have installed the beta version 4.3.2 - and I would like to go back to 4.2.1 or an older 3.x version. Unfortunately there is no 4.2.1 version available on the download site, and the version 3.2.16 is refused for manual upgrade with error message “Testing the firmware with sysupgrade failed.” .
It seems I am somehow stuck and need some direct glinet support for this unit.


Hi. Is it possible to update minidlna to 1.3.3? There are some bugs and security fixes.

They’re working on new firmware based on OpenWrt 22.x so the minidlna version will be whatever’s in those repos: