Incorrect Firmware images for the GL MT3000

I had to reflash my device following the “unbrick” instructions after I lost access to the administration. I had problems getting the correct firmware from the downloads.

In the video it says we should only use IMG files. But the following page does not show any IMG file (at the time of posting this message)

The comments related to the first download (which is a TAR file) clearly says:
This file is for local upgrade in web Admin Panel and Uboot

So I thought the comments about the instructions saying that only IMG being appropriate for uboot in the video were not applicable for this very recent device ?

Then I copied the download link to the “.tar” file, I replaced the extension with a “.img”, and I attempted to download it, and it worked. So I was able to download an IMG file, corresponding to the TAR file listed.

Eventually I was able to get reset my device using the IMG file from the “snapshot”. But getting the correct firmware should not be that complicated.

So can you please confirm whether TAR or IMG files should be used with uboot ?

Either we should use IMG files only with uboot, as said in the video, in which case you should provide the correct links in the downloads for the MT-3000. Or we should use the TAR file with uboot on the MT-3000, in which case the instructions in the video are incorrect.

Please can you take the appropriate action to rectify this, in order to avoid a lot of pain for users who need to unbrick their MT-3000 in the future.

The firmware downloads for GL-MT3000 are for both local upgrade and Uboot:

Some firmware downloads are like that, so the video/documentation should not say only IMG files.

I do not work for and I do not have formal association with GL.iNet

1 Like

Can this be confirmed by someone working for GL.iNet ?

If uboot needs TAR files for unbricking the MT3000, then the questions are:

  • Why do they build and distribute IMG files for this router (with the same URL as the TAR file, just the extension changes), even though they do not provide the link for it
  • Why does the video says a mistake is to use TAR files instead of IMG files with uboot
  • My router did not work after trying to unbrick using uboot with TAR images, and I tried several times.

The instructions need to be cristal clear about which type of file is correct. If there is a doubt, we have to spend hours trying all the possible things that we think may work and it is a real pain. I was just about to return my router after hours of efforts when it eventually worked with a snapshot IMG file.

Please, can the instructions be updated with clarifications, both the written instructions on Debrick via Uboot - GL.iNet Docs and the corresponding video.

Also there is a link to a BIN file on GL.iNet download center (with version 4.1.2). When are BIN files supposed to be used ?