Initial Setup GL-MT300N-00a

Just received this. Connected it to DHCP server using WAN port and see it on the LAN.

Unit runs very warm considering it is not doing anything yet.

Nmap shows it running a web service at port 83 so logged in and was told this was initial setup.

I get to the setting password and enter 12345678 twice but router screen never changes showing;

“Logging in. If you are using wifi, please reconnect after changing password. Then refresh”

What now?

UPDATE: Firefox didn’t work but IE did.

Seems the only way of accessing it is by using wireless as initial setup and then only by wireless as services are not enabled for physical NICS.

I was hoping this device would save us at least that one step since it comes with openwrt already installed but I guess not.

So, as usual, one must start and access the device using wireless, then either update the firmware with your own build or telnet/ssh, etc into it via wireless.

Will continue testing and will now build my own next.

First, connect from Lan or wifi, via 80, not 83

Second, seems it is a browser issue. Use Firefox or chrome please.

Yes, I was using Firefox but it would never set the password. I didn’t try IE and I don’t have chrome installed on the machine I’m working on.

My next item is to make my own build using Image Builder but I don’t seem to find a page for that on the openwrt site.

Does anyone know if this is fully supported in the current branch? I am finding information but nothing very clear yet.

In trunk, choose ramips, 7620 based board, chen choose 300A.

It’s not main yet? I’m nervous about using trunk, I always end up screwing something up.

 

 

I am not sure what you mean “main”.

Do you mean CC1505.1? Actually it is almost impossible to add something to that release now, because it is released.

Trunk is “main” in my understanding.

Sorry, I’m not sure of all the terms. My dev usually takes care of these things for me. As I understand it, trunk means new code which has not been put into the mainstream general now fully supported code. Branch I think is what I mean by that general code.

This is what I’ve downloaded and am looking at using.

http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/OpenWrt-ImageBuilder-ramips-mt7620.Linux-x86_64.tar.bz2

And this profile and these packages.

PROFILE=GL-MT300N

 

libstdcpp ca-certificates libpthread bash curl

-kmod-ipv6 -wpad-mini -wireless-tools -firewall -odhcpd -dnsmasq -kmod-ath9k -uboot-envtools -ppp -ppp-mod-pppoe

-kmod-ppp -kmod-pppoe -kmod-usb-core -kmod-usb2 -kmod-ledtrig-usbdev -kmod-usb-ohci -kmod-usb-hid

 

Can you confirm that this will be ok. I do not need any wireless, usb or routing. I just want this to be a dhcp client.

 

It should be OK. But I didn’t use image builder. You can try the firmware for the device specifically and try to install the packages as well.

https://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/openwrt-ramips-mt7620-gl-mt300a-squashfs-sysupgrade.bin

https://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin

 

That won’t work for me. I need to build my own so I can replicate the devices as they are pre-configured then shipped out.

Also, I need this to be a bridged device but am also wanting to confirm that the following won’t mess up the network.
Someone also said the old 6416 version could only do software bridge so can this one do a hardware bridge?

It needs only to be a pass-through device picking up a dhcp IP from the upstream router/modem.
config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0.1’
option force_link ‘1’
option type ‘bridge’
option proto ‘dhcp’
option ip6assign ‘60’

config interface ‘wan’
option ifname ‘eth0.2’
option force_link ‘1’
option proto ‘dhcp’
option hostname ‘GL-MT300N-00a’

config interface ‘wan6’
option ifname ‘eth0.2’
option proto ‘dhcpv6’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘0 6t’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘1 2 3 4 6t’

I use built root. I didn’t use image builder.

Simple guidance is here: GitHub - domino-team/openwrt-cc: openwrt CC with Domino/GL patches

If you just use it bridge, the network configure could be much simpler:

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0’
option force_link ‘1’
option type ‘bridge’
option proto ‘dhcp’
option ip6assign ’60’

That’s interesting. This is what someone suggested in the openwrt forums but for my 6416, I only used the following and it works fine.

 
config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0 eth1’
option type ‘bridge’
option proto ‘dhcp’

Finally built and got;

/build_dir/target-mipsel_24kec+dsp_musl-1.1.14/linux-ramips_mt7620/openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin is too big"

How is that possible when even this build fits on a device with less space.

Bah, this is frustrating. I’ve removed everything I can think of but it still complains there isn’t enough room.

make image PROFILE=GL-MT300N PACKAGES=“vnstat libstdcpp ca-certificates libpthread bash curl -wpad-mini -wireless-tools -kmod-ipv6 -firewall -iptables -ip6tables -odhcp6c -odhcpd -dnsmasq -kmod-ath9k -uboot-envtools -ppp -ppp-mod-pppoe -kmod-ppp -kmod-pppoe -kmod-usb-core -kmod-usb2 -kmod-ledtrig-usbdev -kmod-usb-ohci -kmod-usb-hid” FILES=files/

if [ stat -c%s "cc-15-05-trunk/build_dir/target-mipsel_24kec+dsp_musl-1.1.14/linux-ramips_mt7620/openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin" -gt 16121856 ]; then echo “Warning: /cc-15-05-trunk/build_dir/target-mipsel_24kec+dsp_musl-1.1.14/linux-ramips_mt7620/openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin is too big” >&2; else cp -fpR /cc-15-05-trunk/build_dir/target-mipsel_24kec+dsp_musl-1.1.14/linux-ramips_mt7620/openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin /cc-15-05-trunk/bin/ramips/openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin; fi

Is the PROFILE name wrong? That’s what shows up when using ‘make info’.

Yet, there is is?

ls -la bin/ramips/

-rw-r–r-- 1 nobody nogroup 3932164 May 3 07:02 openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin

 

 

It is only 3.9MB why it is too big?

Also, Don’t use ath9k. This is not Atheros chips, it is MTK.

Also, are you using MT300N or MT300A?

Not sure what you mean about using ath9k? The profile and packages I am using are listed above.
The device is a MT300N.

Even with the error, there is a resulting sysupgrade file.

3932164 openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin

Is this a bug in the compiler and I need to tell openwrt?

You have kmod-ath9k in your packages. I am not sure by adding - before the package name , do you mean you want to exclude the package from build ?

now you can try to flash to the router via uboot web UI. If it doesn’t work, try another time.

Oh yes, I do have kmod-ath9k but it is commented out so that it will not be included anyhow. I use a similar package build for all of the devices/manufacturers I buy.

Are you sure it’s safe to try this and it will not brick the router?

Seems to have worked. I see port 22 ssh open. However, it will not allow me to log in, saying wrong password over and over again.

When I build, I also include a etc/shadow file so that I can pre-set my password.

UPDATE: It is still using the password I set with the factory firmware. That’s really confusing.

Then, I thin you made the mistake by yourself. Double check your files.