Install openclash on axt-1800

finally got it working.

# ssh to your router
ssh root@192.168.8.1
# type your password

# in router

cd /etc/openclash/core
uname -m
# router cpu is armv7l

# in computer

# follow the instruction to install clash-core, clash-tun-core, clash-meta-core
# if you have to manually download clash-core, clash-tun-core and clash-meta-core
# maybe in here
# https://github.com/vernesong/OpenClash/wiki/%E5%AE%89%E8%A3%85

scp ./your-clash-core root@192.168.8.1:/etc/openclash/core

# in router

# if your-clash-core ends with .tar.gz
tar -xzvf your-clash-core
# or ends with .gz
gzip -d your-clash-core
# remember to change their name

restart router, go to luci, the “service” shows up

in my situation, only clash-meta-core work with my subscription link, so I go to settings check use meta. For some reason I have to use “global” mode to update from my subscription link

if you cannot reach google or youtube, try to flush DNS on your device

there are commands might be useful, do your own research before use them:

# if your curl is broken
opkg install libcurl4

# to find out your local dns(in your computer or router)
nslookup
dig

# restart dnsmasq
systemctl restart dnsmasq

# flush DNS cache
resolvectl flush-caches