Installing/configuring luci packages


I installed adblock plugin from the admin panel but I’m unable to access or configure the plugin. I tried accessing via the admin panel and also via Luci (openwrt) but not able to do it.

Also, the adblock package version in the router is 4.1.3-4 but the latest version on openwrt is 4.1.5-7. How can I update to the latest version?

Apologize if it’s a noob question or already answered.


So you installed Adblock and it can be access by CLI (command line interface). You need to install luci-app-adblock to set up using LuCi, many programs have a add on for LuCi that can be found with luci-app-(insert name of program).

Thanks for the response. Adblock does have an add-on for Luci but it is not listed in the packages list within router’s admin panel or in Luci. Hence my question about how can a openwrt package (in this case listed on openwrt website but not on Glinet router admin panel) be installed?


What is the GL-iNet model and firmware being run?

For it to work in the GL-iNet admin GUI (Graphic User Interface) if must be supported by GL-iNet.

Go to LuCi Uninstall Adblock and reinstall using LuCi, instead of GL.iNet GUI. Log out and log back in shouuld be under system of network in LuCi.

Thanks for the response. I’m using Flint with firmware version 4.2.1.

Ok. will try your suggestion after going home from work. I’ll install Adblock via LuCi but I assume it will not allow or give the option to install the LuCi companion app. will try and report back.


@K3rn3l_Ku5h I tried the suggested steps but it did not help. Installing via LuCi also gave the same adblock version and the LuCi companion app was also not available for installation.Finally i used SSH to install both AdBlock and its LuCi companion app and it went as expected. After installation, rebooted and Adblock was available under services tab in LuCi and was able to configure it.

Thanks for your help and support. Apprecaite it.