Installing soft-ether client



I have GL300M router.

I want to install soft-ether client package from OpenWRT.

Also, I have installed openWRT on my PC. I am able to install soft-ether client from Web GUI of openWRT.

How can I install same on GL300M router ?


There is openwrt package of softether and you need to compile it to a ipk package. But you can use the pre-compiled ipk and install it using opkg.

To do this, use winscp and upload the file to the router then ssh to the router, and install using the following command

opkg install xxxx.ipk


Thank you for that information. Unfortunately, this is really not easy.
To compile the package for the GL_MT300A router, you need to install a virtual machine under debian…
Or there are ipk pre compiled here:

But I don’t know if the package exists. I can’t identify the right pack.
Were you able to install softether? can you tell us which pack to take ?

A tip for the GL iNet team: openvpn is so slow that you should let the possibility of installing other servers more easily.

Thank you in advance


You need to download this one softethervpn_4.21-9613_ramips_24kec.ipk I cannot help to configure but I installed successfully.

root@GL-MT300A:~# cd /tmp/
root@GL-MT300A:/tmp# wget
Connecting to (
softethervpn_4.21-96 100% |*******************************| 1066k 0:00:00 ETA
root@GL-MT300A:/tmp# opkg update
root@GL-MT300A:/tmp# opkg install softethervpn_4.21-9613_ramips_24kec.ipk
Installing softethervpn (4.21-9613) to root…
Installing libreadline (6.3-1) to root…
Installing libncurses (5.9-2) to root…
Installing terminfo (5.9-2) to root…
Configuring terminfo.
Configuring libreadline.
Configuring libncurses.
Configuring softethervpn.
The SoftEther VPN Server service has been started.
The SoftEther VPN Bridge service has been started.
The SoftEther VPN Client service has been started.



Do you know that you are wonderful !

Exactly what I needed !

Thank you very much…


Bought my first Ar300M. Liked it so much I bought bought 2 MT300N-V2. Only critique is slowish openVpn performance. In an effort to address that with another VPN I was seeking to install softethervpn so I bought an MT300A when I discovered the packages wouldn’t install on the Mangos.

Worked until firmware upgrade. Tried to reinstall and got error below:

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for softethervpn:

  •  libreadline *   libncurses *

Is there some change that would account for the error above?

Downgraded to 2.6.1 and SoftEtherVpn installs / runs ok.

Update :

After reflashing the latest firmware I was able to re-install SoftEtherVpn. I used Luci to install the prerequisites first. Then I installed the IPK file. I did have to stop and disable the VPNbridge as it interferes with the windows vpnserver manager I was using to set things up. After that all went well.

Being a Linux noob it also took awhile to learn some things in order to get unstuck.

Don’t get hung up on the ./vpncmd check cmd failing on network connect (0)as that has to do with vunerableSSL3 which has been disabled in the package intentionally. the install will still work.



Hi, tell me please

What a performance softether as a clien?
And on which device and what are the encryption settings.


I could only get the MT300A to cooperate. The MT300NV2 errors out. Something about wrong environment.

Sadly the performance isn’t much better than OVPN. It is better however. The processing power just isn’t enough to provide anything better than 12-15m/s for me. I run 150/10 cable. I get those speeds over wireless.

I was using various encryptions up to SHA256.

I played with various features including connect through icmp/DNS and Nat-T. DDNS also works.

I used an android phone, Windows L2tp, and SoftEtherVpn’s client to connect. From what I gather the client is for SoftetherVpn servers only.

I also tested the ovpn clone feature and it was functional as well. I was able to run both OVPN and softether concurrently which was a surprise.

All and all a versatile software package. It didn’t give the performance gains I was hoping for, but the feature set was worth the time.

Hope this helps.