iOS SMB access using native Files app

Hi Forum,
1st post, If I missed out somewhere, apologies, please let me know.
I’m setting up a Mudi E750 and got to File Sharing. Following the steps in for Windows using SMB2 applied the change to /etc/samba/smb.conf.template. Works fine.
Next trying iOS, yet want to use the native iOS Files app. Selecting the ‘Guest’ option works ok and it is Read Only. However, selecting the Registered User I get an authentication error. I’m using the root user and the normal Web Admin password as suggested. In 99.9% of the cases, this is due to a typo :upside_down_face:, but could it be something else as well? Accessing my NAS using iOS Files as Registered User works OK. Thoughts?

I don’t have the specific gear/equipment you do but my first instinct would be to compare the configuration file (.conf) of your ‘known good’ service on your NAS vs E750’s /etc/samba/smb.conf… provide the NAS has one, of course. I’d be surprised if it wasn’t using some sort of embedded Linux for its OS.

Thanks for your suggestion!
Checked smb.conf on my NAS (Synology DSM, Linux based afaik) and indeed that is different, yet as the smb.conf has hundreds of parameters, such is no surprise. In any case both had the ‘security = user’ setting. The default conf file on Mudi has ‘security = share’, the Mudi manual suggests changing to ‘security = user’ in the Windows example. Not sure if that woudl also apply for iOS. Hence tried with ‘security = share’, but no luck using iOS Files app either.
To be sure tried as well with the SD card formatted NTFS, no change. Back to to Fat32.
Is anyone actually usnig iOS natie Files app with success to read/write shared files on Mudi?