iPhone + GL-MT300N-V2 hotspot works briefly then stops

I have an issue with tethering my iPhone 11 to the GL-MT300N-V2 mango router. I would hook it up to the router using the Lightning cable and I can surf the internet for about a minute, until there isn’t a connection anymore. The computer would stay connected to the router, and the computer can access the router’s configuration, but there would no longer be an internet connection.

If I disconnect the cable from the phone and reconnect it, I can surf the Internet for about another minute, then I get “This site cannot be reached” or “No internet” using the web browser, and opening another browser doesn’t change that outcome.

I’ve connected another computer to the Mango router without success. Either computer can surf the internet for about a minute (or less) when I initially plug in (or disconnect and plug back in) the cable

I previously used OS 14.7 and now upgraded it to 15.2 on the iPhone, without any success of keeping the internet connection alive while tethering. This started happening this Fall; over the Winter thru Summer, the Mango tethered to the phone and worked flawlessly for hours and days at a time.

I even reverted the Mango back to factory settings, but still experience the same “No Internet” issue after a minute (sometimes less).

Is there a firmware update in the works, or is something else amiss?

Can you check

  1. Pls check the power adapter you are using. Is it 5V2A? Using a good power adapter can save lives.
  2. When this happens, pls ssh to the router and use logread to get the log.

I just checked my iPhone 12 with iOS15.2, and the firmware of Mango is 3.203. It works fine.
Here are two screenshots for your information. Please change a 5V/2A adapter or change a USB-lighting cable for iPhone to try it again.

After pulling my hair and searching everywhere , I solved it by disabling low power mode.