IPv6 6to4


I bought a GL-AR300M about 6 months ago. Now I am thinking of using it to follow this tutorial OpenWrt native IPv6-stack [Old OpenWrt Wiki]

Is what is already installed on my GL-AR300M enough to do that or do I need to update/upgrade/install additional software?

In the second case do you have any tutorial teaching how to update/upgrade/install additional software?




For example looking at firmware update found there are two different firmwares: Nand and Nor. Which one is more suitable for what I am trying to do, that is connecting to a special IPv6 server even if my Internet Service Provider only allows IPv4?

I’m not an expert in this, but it seems to me if your first point of connection (your ISP) only supports IPv4, then there is no way to establish Ipv6 downstream?



I am not an expert either, but it seems they developed sort of workarounds for the transition period generally called 6to4 and described for example here 6to4 - Wikipedia. The obvious way to use these workarounds is to have them deployed in a router. OpenWRT already did the work described in the link of my first post and particularly implemented in IPv6-in-IPv4 tunnels (6rd, 6to4, 6in4) but to have it fully functional something should be installed in my GLI mini router since this is obviously not the standard installation.

So I would need some direction to understand what is the more suitable firmware for that and possibly also which software among those mentioned in that link. Well if somebody has some ideas or better experience than me.

Best and thanks

The router support IPv6 but never fully tested in real environment.

You can install 6to4 using opkg and configure.

@alzhao many thanks for your help and kind attention,

I updated the firmware to 2.25 using the UI and the default automatic system. At the bottom of the UI there is written “Model ar300m NAND”. So it seems ok.

Then tried to install the package “6in4” as required by the tunnel administrator , but got a kernel related error whose snapshot is enclosed

I also tried to connect with SSH, tried:

opkg update

opkg install 6in4

but got the same error

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for 6in4:
  • kernel (= 3.18.27-1-e5ed52b8a26964473b4e4d079fbf6f41) *     kernel (= 3.18.27-1-e5ed52b8a26964473b4e4d079fbf6f41) *


I also tried to upgrade to testing firmware, but got this error:

openwrt-ar300m-2.254.bin successfully uploaded
Version unknow
MD5 b0098be1e33ef36820b40214b540dfa1
Verification result Error: Firmware is not for this hardware.

What should I do now? I have seen another similar thread where you suggested to install this GL.iNet download center Is this updated? Also there is only a tar, with no .bin file inside. Which is the proper way to install it?



I found that even the tar can be used to upload firmware. So tried to upgrade to testing but the installation of 6in4 did not work.

Finally installed this firmware GL.iNet download center and was able to install 6in4 after opkg update via SSH

I would suggest suggest to add to firmware index a few words to explain what is the use of the particular firmware. For example “to install packages via opkg” or “openvpn ready” or whatever. I spent a couple days trying to find out that and was lucky, but many people will give up.





@francus, I am not sure why you cannot install package in v2.25. Seems it is very strange. It should have no problem.

For testing firmware you will not be able to install packages. Also for AR300M nand, you need to download the .tar file, not the .bin file

Additional problems here:

Firmware GL.iNet download center gives me authentication problems with Luci. I mean it authenticates and takes me to “status” but after that when I try to go to network interfaces it takes me again to the login page. I tried to reboot various times. Well a couple of times I got to the network interface page, but was taken to the login page immediately after. It is too much instable to be usable.


Is there any other firmware without this authentication problem and that will let me install packages on my Ar300m?


@francus, when you change to the clean firmware, did you reserve settings?

I do not remember, but probably yes because it remembered the password to connect to wifi.

Is this wrong? Was I supposed to avoid reserving settings?

I think the idea is that if you are having problems, it can be blamed on reserving the settings - so do a clean install and report back.

Many thanks Glitch

Ok, I reinstalled the clean firmware WITHOUT reserving the settings. Now no more authentication problems :-))

However I cannot connect with WAN cable, When i click on interface/connect, it tries, but cannot connect. I even tried to change cable. When I plug the same cable into my old router (also with openWRT) it works and I get internet access.

So I wonder what may be the problem since I just made a clean reinstall and touched nothing, just default settings.

This is the system log https://pastebin.com/z4QU0GyA

connected but cannot get IP. Can you post content of /etc/config/network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘’
option netmask ‘’

config globals ‘globals’
option ula_prefix ‘fd2a:78ab:ffd7::/48’

config interface ‘lan’
option ifname ‘eth1’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option netmask ‘’
option ip6assign ‘60’
option ipaddr ‘’

config interface ‘wan’
option ifname ‘eth0’
option proto ‘dhcp’

config interface ‘wan6’
option ifname ‘eth0’
option proto ‘dhcpv6’

Hello alzhao

any idea?

Is /etc/config/network correct ?

Workaround ?

Please help


If nobody replies I understand there is no solution :-((

On some other thread I have seen that in same cases you suggest to compile it together with the program that you wan to to install, in this case 6in4. Would that be a solution to my problem of connecting with WAN network cable and getting a IP address?

If yes, is it complicated to do? Are there instructions somewhere?



It was my fault I am sorry, forgot the the connection should use PPPoe. This is why it was unable to get an IP.

Ok, going along, when I try

opkg update, get these errors:

Downloading 404 Page not found - GL.iNet.
Signature check passed.
Collected errors:

The same I was able to install 6in4, just wonder if these errors represent something serious and if there is a fix.