Issue on AR750 3.026-0719 vpn policies

Hi,
I have upgraded my ar750 an now to have working vpn policies and goodcloud I have to select “use vpn for all services on the router” but in goodcloud I see vpn ip for the router not my public ip so if vpn go down I can’t reach my router by cloud…
I’ve revert firmware and reconfigured all but nothing…Naturally adding goodcloud.xyz in the exceptions of vpn not resolve the issue because this site is only to authentication I think…
On the 3.022 It was ok…“use vpn for all services on the router” not selected, vpn policies working and goodcloud working on my public ip.

Any solutions about?
Thanks

Please read this docs https://docs.gl-inet.com/en/3/app/cloud/#goodcloud-and-vpn
If router run vpn client, goodcloud will use vpn by default. If you don’t want goodcloud service use vpn, please enable vpn policies and don’t select ‘Use VPN for all processes on the router’.

I have just test this on AR750 + 3.026-0727 + wireguard client, it work.

If I don’t select ‘Use VPN for all processes on the router’ goodcloud is not online and rules of vpn policies are not working. With 3.022 I did not select ‘Use VPN for all processes on the router’ and goodcloud was online with my public ip and the rules of vpn policies were working…This is the issue…
My vpn is openvpn not wireguard and I have AR 750 (not S).

@luochongjun pls have a check.

@alzhao
Thanks. I’m ready for testing any solutions. Meanwhile I have reloaded 3.22 and all is ok.

Hi,
Any news about…?

Hi,

Sorry for reply late.
I used openvpn to test the firmware of ar750-0729 and did not find this problem.
I fixed a DNS BUG on July 26th. Is the firmware you tested the previous version?

@luochongjun
Thanks. I’ll try this new release and I’ll report results here.

Nothing to do…Same issue with new firmware too.

My case
Firstly, I choose to Use VPN for all processes on the router. I saw my VPN IP 85.25.210.73 in the goodcloud
K%60K_SZDUD5FJF~O4WMD7(TK

Then, Do not choose to Use VPN for all processes on the router. I see my public IP 113.116.56.238 in the goodcloud.
HY%5DIH3Y%7B~_~%5D(EXLBXVF~36

The network situation is always complicated, and I can’t make sure that my situation is exactly the same as yours. You can log in the background of the router first to confirm whether the router has gone through VPN

@luochongjun
Thanks for the help. My lan situation is like your and I do your same steps but if you uncheck use vpn for all process goodcloud is not connecting…
What have I to log and by what command?

You can use ip route get 8.8.8.8 check data path on the router.
You can export logs using the logread command.

Now I have 3.022 on board. I hope to do some tests during weekend…

Traffic to 8.8.8.8 is rightly going via vpn.
I’ll stay on 3.022 waiting for a new firmware…

Do you choose Use VPN for all processes on the router?

Naturally no. With previous firmware it’s all ok…