Issues on AR750 after upgrading to 2.264 (testing)

As I described in this post, I didn’t see a stable release of the 2.264 firmware for AR750. As recommended by Alzhao, I installed the testing firmware. However, I ran into a number of issues, so I did a reset to factory defaults. Unfortunately, things were still not happy:

  1. The two wifi networks strangely came up with the names “GL-GL-AR750–5G” and “GL-GL-AR750-” (note the trailing slash).

  2. Those networks also both came up as 2.4GHz. There was no 5GHz network.

  3. The ddns indicator at the bottom of the main settings page simply showed “” (missing hostname)

  4. Logging in via ssh, I saw a strange hostname with double “GL”:
    root@GL-GL-AR750:~# uname -a
    Linux GL-GL-AR750 4.4.93 #0 Thu Dec 14 10:15:06 2017 mips GNU/Linux

  5. the configuration in /etc/opkg/distfeed.conf still had entries for 2.263, rather than 2.264

  6. I had to uncheck the rebind protection option in order for the device to see DNS entries on its upstream connection (which I did not have to do on 2.263)

At this point I decided it was probably better to revert back to the 2.263 firmware.

I had the same issues. I just reverted to 2.23 via uboot, then reflashed 2.24 via the web UI while keeping the “Keep Settings” checkbox checked. The bugs 1, 2, 3, 4, and 6 all disappeared after doing this.

It’s good to know that a simple upgrade works. The reason I reset to factory defaults was for problem 5. I manually edited the conf to point to the 2.264 location, but then opkg update had signature clashes. Even when I cleared the signature cache, it was saying that nearly all the packages were incompatible.

This is an unrelated question, but I assume I can’t simply point at the official lede packages to get something that isn’t in the GLinet package repository? My ultimate goal is to install some packages but it seems that GLinet hasn’t compiled them. I didn’t want to have to compile my own firmware to get the standard lede - I’m happy with the GLinet customizations.

I’m not sure if this is true, but don’t the GL.iNet routers have a special architecture that the LEDE repos don’t have compiled? For me, uname -a returns Linux UXFY-RT 4.4.61 #0 Tue Oct 24 01:31:47 2017 –> mips <– GNU/Linux.

Hello, you can test v2.27, which is in GL.iNet download center.

Yes, 2.27 fixes all of the issues that you listed @dino. It also adds some more features (like OpenVPN server, ability to program the “mode” switch under the router, etc.)

You can feedback the bugs.