Issues with Downgrading Firmware

I have a B1300. I tried upgrading to firmware version 3.027 and noticed the VPN was missing, so I reflashed back to 3.026. However now I am seeing some weird things. For example, I only see one wired client on the clients page (the machine I am accessing the admin through). No other wired clients appear of any wireless clients. On the admin I see the “Mesh” menu (I have 2 of these in mesh mode), but when I click on it, it takes me to what the “Wireless” screen was before I did the mesh. The devices are still in mesh mode which I have verified. Everything seems to be working ok, but the admin screens are off. Is there another way to reflash the firmware outside of the admin? I feel like when I downgraded back to 3.026 something didn’ t go right. I reset the firmware, rebooted, etc multiple times and still have the issue. Any help is appreciated!


Id suggest flashing via uboot as next course of action and see how that goes.

Thanks, that solved it. So something doesn’t get cleaned up correctly just using the UI to downgrade. Thanks again!