Issues with recognizing fiber optic signal

I own an AX-1800 Flint and a couple of MT-1300 Beryls. I just recently had fiber optic internet installed in my house by CenturyLink Quantum Fiber. They’re provided modem/router is working fine with speeds up to 700mbps per an internet speed test. However, when I connect any of my GLiNet routers to the Optical Network Terminal (ONT), they do not recognize the signal. On the router GUI, it prompts me to select the protocol (DHCP), but when I do, the connection times out every time.

Steps I have tried:
Update/reset firmware
Multiple routers
Multiple cables
Centurylink remote rebooted my ONT

I have a Calix Gigapoint 803g optical network terminal provided by CenturyLink

Maybe there are some configurations I need to do in Luci? Please help!

So I am slightly unclear on what you are attempting to plug the the routers into. The OLT cable may look like a CAT5,5a,6,7 cable but it is not compatible with Ethernet. I believe that OLT connections are colored green and Ethernet should be yellow, blue or silver. A picture of the ports of the device might help. You could also have a bad or unsupported Ethernet cable. You want a Cat 5a at the very least.

ONT stands for Optical Network Terminal​. It is an outlet to the Internet for fiber technology just like how a cable modem is the outlet for a coaxial cable Internet connection. It is a device that communicates directly with an Internet service provider (ISP) to get a fiber-optic Internet connection in your home or office. However, an ONT is specific to fiber-optic Internet so you cannot use an ONT with an Ethernet over coax or MoCA device like a cable modem, router or cable modem router, for example.

This page focuses on ONT, but there are other fiber technology abbreviations to know. The other abbreviations are:

  • PON​, which stands for ​Passive Optical Network.​ A PON is the “last stop” between you and your ISP. More specifically, the PON is the last part of the communication chain that reaches your home.
  • OLT​, which stands for ​Optical Line Terminal. ​An OLT is the device that serves as your ISPs endpoint of the PON. ​An OLT provides the interface between a PON and a service provider’s core network.​ ​For more, c​heck out our OLT page.
  • ONU​, which stands for ​Optical Network Unit. ​This is a combo device that functions as both an ONT and OLT. That means an ONU acts as both the endpoint of the PON and as the interface for the user. ​For more, ​check out our ONU page.

Overall, a PON consists of an OLT at the service provider’s central office and a number of ONUs or ONTs near end users.

Thank you for the info!

The ISP provided me with these two devices: A Calix Gigapoint 803g ONT (pictured) and a Centurylink C4000xg Wifi 6 modem/router combo. However, I didn’t think you needed a modem with Fiber. That’s what I don’t understand. I thought the ONT was the “modem” that translates optical signals to digital in a Fiber network.

I am trying to plug my GLiNet routers directly into the black ONT INSTEAD of using the CenturyLink router/modem. But I don’t get a signal. The CenturyLink router/modem works just fine though. So I’m wondering if the modem part DOES have something to do with it…

The C4000XG is a router, not a “modem”, but CenturyLink calls it a modem because people are familiar with the cable and DSL Internet terminology. The ONT is not really a “modem” either, but it does a similar task as a cable or DSL modem.

Replacing the C4000XG with your own GL.iNet or other brand router may require getting the PPPoE and VLAN settings from CenturyLink, then configuring the same in your own router. You may be able to get this information if you have Admin access to the C4000XG settings, or by contacting CenturyLInk technical support.

I do not work for and I am not directly associated with GL.iNet

Yeah I think you need to talk to you ISP like wcs2228 suggested. You may also need to use the Beryls as they have a more current OpenWRT with newer packages, even though the flint has faster processors and a dedicated network processor. The ONT might not be hotswappable and may need to be reset each time a new device is plugged into the Ethernet.

Only other thing I can think of is that the Calix Gigapoint 803g is paired to the centurylink C4000xg because of the uninterrupted power supply in the Calix Gigapoint 803g.

That’s the avenue I have been trying now. I have already confirmed with the ISP that they are not using PPPoE. Just regular DHCP. Places on the internet tell me that they use VLAN tag 201. I dont quite know how to configure that though. I know it is in the Luci settings though. Can you walk me through that?

Hi there,

You could do this by vlan notation on the wan side:

Change the wan interface into wan.201 and I think since they say its just dhcp… either they mean you could keep it as a dhcp client, or you have to use pppoe, alot of isps seem to have vlans from the wan side, often voip or tv is different aswell.

On the GL-AX1800, I think you can set up VLAN’s via LuCI → Network → Switch. I do not know whether the GL-MT1300 has the same.

If the Switch page is available, I prefer to use it, just to be on the safe side. You should back up your setting just in case.

I do not work for and I am not directly associated with GL.iNet

New problem…the “Add” button under Luci/Network/Switch is broken. It won’t add a configuration. I’ve tried enabling/disabling, rebooting, and making sure my firmware was up to date. What about a CLI option?

You should be able to update the VLAN ID field from 2 to 201 and tag the port, then click Save & Apply, without adding a new entry. Otherwise, edit the /etc/config/network file in SSH.

Also, check the WAN zone is correct afterwards via LuCI → Network → Firewall.

I do not work for and I am not directly associated with GL.iNet

One thing you should know:

Modems tries to lock mac address of the router. I.e. You ONT modem only accept the original router it is connected.

If you want to change router, you have two options:

  1. Mac clone: you close the mac of your old router to the new router. Then it will connect immediatelly.

  2. Reset the modem: The modem can be reset then it will accept new router. You can do this these method: (a) reboot the modem; (b) If reboot does not solve, turn it off and wait for some time (e.g. 10 to 60 minutes) then to power it on. (c) Just call the ISP customer services asking them to reset the modem because it does not accept new router.

Generally we resolve using 2. (b).

Sorry for the late reply. The VLAN Tag was the solution! Here is a quick wrap up of everything:

A quick Google search told me that my ISP’s VLAN tag was “201”

I navigated to the following menu:

Router GUI/Advanced/Luci GUI/Network/Interfaces/LAN/Physical Settings

At the bottom of the page in the “Custom Interface” block, I typed in “eth0.201” (case sensitive. “Eth” does NOT work) and clicked “Save and Apply.” I then exited the Luci GUI and went back to my Router GUI. I don’t even think I had to restart the router. My ISP suddenly populated my IP address and now I am reaching speeds up to 700mbps over my 5G Wi-Fi network.

Thanks for everyone’s help!