Issues with Schlage Encode WiFi Door Lock with Flint and Velica?

Have just purchased a Schlage Encode WiFi Door Lock.

My current standard network setup has been Velica Firmware 3.211 Beta 4 15-1
Had heaps of issues with connecting the door lock, getting the doorlock recognised (lock not reachable) by the Android App and Alexa skill. Other IOT devices (Tuya smartbubs) seem to work fine.

Thought I’d try Flint Firmware 3.208 Exactly the same issues as above.

Show’s as a client.

Tried changing Band and Bandwidth and b/g/n only on the Flint, still no joy :frowning:

Grabbed and Mango and a Beryl (sorry don’t know what firmware), all worked fine.

Pulled out an old Convexa S1300 (Firmware 3.105) and this worked fine. Upgraded to stable 3.211 Beta 6 all worked fine.

Something “strange” with Velica and Flint but only for this device. :frowning: Anybody had similar issues and have any ideas how to remediate?

Tried set wifi in WPA-mixed?

Also try use different SSID for 2.4G and 5G.

Neither of those worked either :frowning:

Seems you are not alone:

Strangely though it works on a Convexa B, Mango and Beryl, but not Flint or Velica…

You can try the workaround in the thread.

It seems the Schlage is finicky and some got it working, some not.

Hi limbot:

For Velica V-3.207,Can it(Door Lock) link normally?
Is Velica Router mode or MESH mode?

Could you send me a copy of logread while the Door lock is connected to WiFi?

Hey Zhang Li

  1. My Velica 2 node mesh was recently updated to 3.211 Beta 6.
  2. Did not try on 3.207

What I have done:

  1. Tried to connect to WiFi on Velica - no go (Mesh SSID=)
  2. Tried to connect to 2.4Ghz on Flint - no go (2.4 SSID = ) (5.0 SSID=
  3. Tried to connect to Mango - everything all good , setup lock (2.4SSID=)
  4. Reinstate Velica - I can see the Schlage lock in clients however I cannot control the lock via the app and Alexa skill tells me it cannot see it and to check network connection and/or power
  5. Setup 2 node Convexa (Mesh SSID = ) All works well.
  6. Tried to connect to Beryl - everything all good (2.4 SSID = ) (5.0 SSID=
  7. Have tried WPA/WPA2-PSK, have tried different set bands, have tried changing bandwidths…

Log being sent seperately.


As you can see I’ve managed to setup the device on a 2.4Ghz only Mango and when converting across to other syste


I pulled down one of my mesh nodes and started building up from scratch.

I have worked out the issue. For some reason enabling Cloudflare as DNS causes the issue. Once I’ve turned this off, everything works fine on my Velica mesh.

I haven’t played with the Flint to see if this fixes that as well as I’ve run out of time to diagnose today.

Very strange since all my other IOT devices that talk to their cloud servers (Tuya, EUFY) work fine with Cloudfare enabled.

Something to keep in mind if having issues with IOT devices.

Thanks you @lizh for all your effort and help.

1 Like