Just this thing

I just got this thing and trying following instructions. I am able to navigate to Then I am trying using it as a repeater for an xfinity hotspot. After scanning available wifi networks I can see the hotspot. But when I select it it does not prompt for credentials although on the top you see message “success”. As the result, no Internet. So, how do I connect to a hotspot?

Forgot to say, Success is with ! point at the end.


What thing are you talking about?

Can you write the product, what firmware version you are on.

GL-AR7505-EXT. 750 Gigabit Travel Router.

Have you checked this guide

I am trying configuring GL-AR7505-EXT using my PC. Read the article again. So, cloning the MAC address is the only way to make it work?

Because xfinity has an app that you have to use, so clone MAC address may be the best way.

But I am not sure about not cloning MAC address. I don’t have xfinity WiFi myself.

I see. However I am not optimistic anymore about the whole hotspot deal. I haven’t been using it too much. It worked fine, better than fine. But now, connecting to it directly I cannot access a half of the sites I am trying. Strange.

After hours and hours of trying I finally got it working. I did not clone the MAC address. While I was trying it some point I was presented with a Xfinity login screen where I entered my credentials. But now I am not sure anymore if that actually even happened. As of now I cannot bring the hotspot back. After scanning and selecting xfinity I get this success! thing, but no connection.

I followed instructions for cloning a MAC address. Yes, it worked… for exactly 2 mins and then xfinitywifi was gone from the device. I tried cloning agan. Connected my phone to xfinitywifi and started playing youtube video. This time it did not work. I have a feeling I have a BAD device.

Do you mean the router disconnect from xfinity by itself?

What is your firmware version?

Can you try the latest?


Firmware: OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.196.56128-9112198). Upgraded with openwrt-ar750s-3.029-1106.tar. Did not help with the hotspot, and I think it got even worse. PC disconnects from it in a short while. But dont worry, we have Amazon that takes everything back nowadays.